Camera exposure setting not working?


Product: [Bebop/Bebop2]
Product version: [3.3.0]
SDK version: [3.10.1]
Use of libARController: [YES] (Only for ARSDK)
SDK platform: [Unix]
Reproductible with the official app: [YES]

I would like to use Bebop’s camera to shoot dataset for photometric camera calibration simmilar to sequences in the mono-dataset. Especially sweep and vignette sequences because these are used for photometric calibration.
In order to create the dataset I need to be able to set exposure time of the camera.

I have tried to set the exposure with the function described in the documentation without any visible effect on images taken. Even in the EXIF metainformation available in the pictures saved onboard there is no change in Shutter speed, Exposure time, Exposure program or Exposure mode information for different exposure value set. I do not see any difference even if I take pictures with FreeFlight app and set exposure to different values from -3 to 3 using the slider provided in the application.

Is it possible to get control over camera exposure time on Bebop drone?
Maybe I am just missing something. Thanks for any feedback.

Edit 1: Originally I used Bebop 1 - exposure setting had no effect. Recently I was able to try to set exposure on Bebop 2 and it worked as expected. Before my experiment I have updated firmware on Bebop 2. I will check whether the firmware update on Bebop 1 will make the exposure setting work as well.

Edit 2: Checked: Setting exposure on Bebop 1 (firmware 3.3.0) does not work.



You’re right, this event does not seem to be taken in account on the Bebop 1 (Fw 3.3.0). I’ll talk to the firmware team to see when it will be fixed.

Thanks for reporting.


It will be fixed in the next Bebop’s firmware release.


Thanks for pushing this up :slight_smile:
Looking forward to test the new firmware.


The 4.0.4 firmware version for Bebop has been released. The camera exposure should work now.



I tested bebop 1 with 4.0.4 firmware. The exposure setting is working now.