Connection lost of BebobDroneReceiveStream


I’m a newcomer in this drone area.
The goal of my project is to implement an autonomous flight by using Bebop and Opencv.

I tried to install SDK 3.0 in Ubuntu 14.04 as guided. Finally, it seemed to be successful because all items of Generic and Unix are green after Unix running

And then, it was decided to run a sample, BebobDroneReceiveStream, given by Parrot. When I entered in the corresponding directory, make and make run sequentially without any modification, the result was shown as the following picture. I think the first error can be ignorable in case of not using a joystick. Am I right?
The second error, connection lost(too long time without reception), is critical to run the sample program, I think. How can I solve this problem? or which step I skipped?
Thanks for your help in advance.



Hi @pineland!
You are right that the warning about joystick can be ignored in case you don’t have it!
For the second warning about mplayer it mean that you didn’t install mplayer probably. Without mplayer you can not display the streamed frame from drone’s camera (I suggest that you use OpenCV in case you need to do image processing or eventhough for displaying only. You can refer to this post for more detail about using OpenCV: Bebop and OpenCV)
Most important thing here is that you can not connect to your drone. Did you check for connection? You should connect the drone with your phone and test the flight by FreeFlight3 app first to make sure.
Best regards,
Le Thai Son.


Hi @darknet!
I really thank you for your comments. I still have two questions.
First, I think mplayer was already installed as the below picture. Why does the second warning occur?
Second, I also checked for connection as the following. The ping test is successfully done as shown. Of course, my phone can connect to and control my bebop by FreeFlight3 app. I don’t know what the problem is. What else I’d like to say is that my ubuntu environment is working under VMware player. That can occur some problems?


Hi, there. I encountered the situation, too. In the beginning, I only installed mplayer from apt-get, and I ran this example, not any media can be seen. then, I managed to solve it by installing mplayer from source code: building, compiling and installing. After that, when I ran the "receive " example, I can see the view of the camera. But I still can’t see the media when I ran the ”decode“ example, I don’t know why~ maybe, you can try and help me with it~