Move camera during moving Bebop


Product: [Bebop/Bebop2]
Product version: [1.0.4]
SDK version: [3.11]
Use of libARController: [YES/NO]
SDK platform: [iOS]
Reproductible with the official app: [Not tried]

Hello there,
I’ve noticed that if I call the method to move the camera (setCameraOrientationV2) and at the same time I move the bebop (setPilotingPCMDYaw, setPilotingPCMDGaz for example), the bebop ignore the movement of Bebop and performs only the camera movement.
That is dangerous because if I give 100 gaz and then move the camera, the gaz will be locked at 100 until I stop to move the camera.
I crashed a time because I moved forward and then I moved the camera.
What’s wrong? I have to modify something or it is a normal behaviour?
Can I perform both move camera and move bebop or not?


I have almost the same experience, but I learned that you must limit the camera move commands per second or you can flood the connection with this command and block the PCMD commands ! I had issues with this and almost crashed the drone while testing automatic pitch control of the cam to target some point at the ground…

I think this as something to do with the recent changes between ACK and non ACK buffer for the camera moving cmds.

@Djavan or @Nicolas could you confirm or infirm this ?



We will test asap to confirm what you are experiencing.
However, the PCMD commands should not be blocked if you use the set_ commands (and not the send_ ones).


Thank you Djavan for checking it.
As I wrote, I use always set_ commands instead of send_ as the instruction says.
I had the same result testing it with the SDKsample project.



the SDK version 3.12 is fixing this bug.

Thanks for reporting.


Great news Djavan!
Do you know if this new SDK version has the velocity camera movement?



The CameraVelocity commands exist in the SDK, but are not yet implemented in the drone firmware.

We will make an announcement here when the firmware will add support for these commands.



Ok thank you Nicolas!
We all look forward to it!


I’ve just tested the new SDK and I can confirm that the problem of this thread is fixed!
Well done! Thank you!


Ah so this could be causing my issue then