Not able to connect to slamdunk over usb


Hey guys,

I have been using slam dunk for a month, it connected as soon as I connect the usb to the computer. but recently I am having trouble connecting to the slamdunk. It tries to establish an ethernet connection, but does not succeed. Kindly help me solve this issue.


Gazebo simulation with slamdunk model
SLAM DUNK behavior on losing track
Not able to communicate to mater


I have the same problem, and it is quite annoying.
Did you manage to solve this issue ?


If you plug in a raspberry pi Wi-Fi adapter it will make an AP you can connect to and SSH in to see what the issue is. Not a fix but another way to connect.


Thank you Koopa, but I really want to connect it by usb, as my working computer does not have the wifi.
I have phoned and e-mailed the parrot service customer, they told me that they would consider my problem, but never gave me any answer.
I don’t think parrot will help me one day, and I don’t know if they really considered my problem, maybe because they don’t care.
I am very disappointed.


I have the same problem…
Did you get a response from the parrot service ?
Thank you


I have the same problem also.
I have to input an IP manually on my PC every time.


I resolved my problem to use recovery (


It works! Thank you Genjou.


You solved this connection issue by doing a update? Did you do it with a USB flash drive?


I have the same issue. Did you manage to solve it? Could you please tell me the steps if possible?


You just have to copy the tar.gz file to the USB, and turn on the slamdunk with the key on.


Thanks! I will try to do it. It is really irritating.


Even I am not able to connect it. It started all of a sudden, without any reason. I am still able to ping the dunk from Windows environment. Does performing the update using USB flash drive as suggested in the comments will result in loss of my data? Thank you.


I stopped using the device, so I don’t know. The costumer service and the product both are terrible!!


The usb update wipes everything, yes.

But you say you are able to ping the slamdunk on windows? But not on linux? (or maybe you are not using it) And you are not able to ssh to it?


Yes, I was able to ping the slamdunk in Windows and there were no packet losses. However, I was unable to ping or SSH on Ubuntu. Apart from that, I found a solution which worked fine for me. Here is what it is, incase any one is interested. This works well when you connect SLAMDUNK with Ubuntu(14.04) system. Or at least worked for me.

  1. Connect SLAMDUNK with your laptop through USB interface.
  2. It will show Wired connection 1 probably, which is the name of the connection.
  3. Go to edit connections, click on Wired connection 1, and then click on edit.
  4. Go to Ethernet tab and select MAC address of the SLAMDUNK.
  5. Go to IPv4 Setting tab, select manual in the dropdown menu.
  6. Click on add button, give under address tab. as Netmask and as Gateway.
  7. Save the settings and try to reconnect.

This solution worked for Ubuntu 14.04 and 16.04. I am not sure if manually connecting this way is a proper solution or not. But it works for me at least.