Problems Configuring the Network Device


#1

[I have try several USB and PCI cards but no one works. I have use EDUP EP-N8531 RT5370|rt2800usb and TP-LINK TL-WN722N v2. There are any further documentation in order to configure those cards? I am using UBUNTU 16.4 and Debian 9.4, but I have always the same problem: the cards don’t work with ap master mode. ]

Thank you for your answer.

I have overtaken the last problem, but I cannot do the same with the next steps:

I have already managed to install the EDUP card and run the AP mode using hostapd. But now when I boot sphynx the driver crashes and disappears from the device list (iwconfig). How should hostapd be configured for this to work?


#2

TP-LINK TL-WN722N v2 is not compatible with sphinx. It comes with a different chipset than v1.10. That’s why v1.10 is recommended.

The model EDUP EP-N8531 should be working. You do not need to configure hostapd by yourself. Sphinx has its own instance and configure it automatically.

When you run sphinx, do you see something wrong/suspicious in the logs provided by systemd (journalctl)?


#3

Thank you very much for your quickly answer!
Yes, I have a lot of messages, but here you have a selection from the ones with error or important information when I start sphinx:
ar 20 00:30:56 Guibian tracker-extract[1222]: unable to create file ‘/run/user/1000/dconf/user’: Permiso denegado. dconf will not work proper
ly.
mar 20 00:31:05 Guibian NetworkManager[492]: [1521502265.0687] manager: (fd_veth_peer0): new Veth device (/org/freedesktop/NetworkManag
er/Devices/5)
mar 20 00:31:05 Guibian NetworkManager[492]: [1521502265.0744] manager: (fd_veth0): new Veth device (/org/freedesktop/NetworkManager/De
vices/6)
mar 20 00:31:05 Guibian systemd-udevd[1695]: Could not generate persistent MAC address for fd_veth0: No such file or directory
mar 20 00:31:05 Guibian systemd-udevd[1693]: Could not generate persistent MAC address for fd_veth_peer0: No such file or directory
mar 20 00:31:05 Guibian avahi-daemon[430]: Joining mDNS multicast group on interface fd_veth0.IPv4 with address 10.202.0.254.
mar 20 00:31:05 Guibian avahi-daemon[430]: New relevant interface fd_veth0.IPv4 for mDNS.
mar 20 00:31:05 Guibian NetworkManager[492]: [1521502265.1342] device added (path: /sys/devices/virtual/net/fd_veth_peer0, iface: fd_ve
th_peer0): no ifupdown configuration found.
mar 20 00:31:05 Guibian avahi-daemon[430]: Registering new address record for 10.202.0.254 on fd_veth0.IPv4.
mar 20 00:31:05 Guibian kernel: IPv6: ADDRCONF(NETDEV_UP): fd_veth0: link is not ready
mar 20 00:31:05 Guibian firmwared[1392]: I firmwared_instances: launch_instance “/usr/share/firmwared/firmwares//ardrone3-milos_pc.ext2.zip.ef8
783c8-93c1-3439-a73b-fed81c699154.firmware”
mar 20 00:31:05 Guibian NetworkManager[492]: [1521502265.1606] devices added (path: /sys/devices/virtual/net/fd_veth0, iface: fd_veth0)
mar 20 00:31:05 Guibian NetworkManager[492]: [1521502265.1607] locking wired connection setting
mar 20 00:31:05 Guibian NetworkManager[492]: [1521502265.1608] get unmanaged devices count: 1
mar 20 00:31:05 Guibian NetworkManager[492]: [1521502265.2042] devices removed (path: /sys/devices/virtual/net/fd_veth_peer0, iface: fd
_veth_peer0)
mar 20 00:31:05 Guibian NetworkManager[492]: [1521502265.6711] device (wlxe84e06277173): state change: disconnected -> unmanaged (reaso
n ‘removed’) [30 10 36]
mar 20 00:31:05 Guibian NetworkManager[492]: [1521502265.7234] device (fd_veth0): link connected
mar 20 00:31:05 Guibian kernel: IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
mar 20 00:31:05 Guibian kernel: IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
mar 20 00:31:05 Guibian kernel: IPv6: ADDRCONF(NETDEV_CHANGE): fd_veth0: link becomes ready
mar 20 00:31:05 Guibian firmwared[1392]: W firmwared_log: Command line is not complete. Try option “help”
mar 20 00:31:05 Guibian firmwared[1392]: E firmwared_instances: invoke_net_helper config returned -125
mar 20 00:31:05 Guibian avahi-daemon[430]: Interface fd_veth0.IPv4 no longer relevant for mDNS.
mar 20 00:31:05 Guibian avahi-daemon[430]: Leaving mDNS multicast group on interface fd_veth0.IPv4 with address 10.202.0.254.
mar 20 00:31:05 Guibian avahi-daemon[430]: Withdrawing address record for 10.202.0.254 on fd_veth0.
mar 20 00:31:05 Guibian NetworkManager[492]: [1521502265.7702] devices removed (path: /sys/devices/virtual/net/fd_veth0, iface: fd_veth
0)
mar 20 00:31:05 Guibian NetworkManager[492]: [1521502265.7703] get unmanaged devices count: 0
mar 20 00:31:05 Guibian NetworkManager[492]: [1521502265.8553] device (wlxe84e06277173): driver supports Access Point (AP) mode
mar 20 00:31:05 Guibian NetworkManager[492]: [1521502265.8571] manager: (wlxe84e06277173): new 802.11 WiFi device (/org/freedesktop/Net
workManager/Devices/7)
mar 20 00:31:05 Guibian NetworkManager[492]: [1521502265.8951] devices added (path: /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2
/2-1.2:1.0/net/wlxe84e06277173, iface: wlxe84e06277173)
mar 20 00:31:05 Guibian NetworkManager[492]: [1521502265.8952] device added (path: /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/
2-1.2:1.0/net/wlxe84e06277173, iface: wlxe84e06277173): no ifupdown configuration found.
mar 20 00:31:05 Guibian NetworkManager[492]: [1521502265.8953] device (wlxe84e06277173): state change: unmanaged -> unavailable (reason
‘managed’) [10 20 2]
mar 20 00:31:05 Guibian kernel: IPv6: ADDRCONF(NETDEV_UP): wlxe84e06277173: link is not ready
mar 20 00:31:06 Guibian kernel: IPv6: ADDRCONF(NETDEV_UP): wlxe84e06277173: link is not ready
mar 20 00:31:06 Guibian NetworkManager[492]: [1521502266.6140] device (wlxe84e06277173): set-hw-addr: set MAC address to 76:A9:92:E2:F5
:E1 (scanning)
mar 20 00:31:06 Guibian kernel: IPv6: ADDRCONF(NETDEV_UP): wlxe84e06277173: link is not ready
mar 20 00:31:06 Guibian NetworkManager[492]: [1521502266.9569] sup-iface[0x55a649a67b40,wlxe84e06277173]: supports 4 scan SSIDs
mar 20 00:31:06 Guibian NetworkManager[492]: [1521502266.9583] device (wlxe84e06277173): supplicant interface state: starting -> ready
mar 20 00:31:06 Guibian NetworkManager[492]: [1521502266.9583] device (wlxe84e06277173): state change: unavailable -> disconnected (rea
son ‘supplicant-available’) [20 30 42]
mar 20 00:31:06 Guibian kernel: IPv6: ADDRCONF(NETDEV_UP): wlxe84e06277173: link is not ready
mar 20 00:31:08 Guibian NetworkManager[492]: [1521502268.2910] device (wlxe84e06277173): supplicant interface state: ready -> inactive
mar 20 00:31:08 Guibian ModemManager[422]: Couldn’t check support for device at ‘/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2’:
not supported by any plugin
mar 20 00:31:40 Guibian sudo[1775]: gdiez : TTY=pts/3 ; PWD=/home/gdiez ; USER=root ; COMMAND=/bin/journalctl
mar 20 00:31:40 Guibian sudo[1775]: pam_unix(sudo:session): session opened for user root by (uid=0)

.


#4

It seems an error occurs at this point. To get a better understanding, could you please modify the file ‘/lib/systemd/system/firmwared.service’ so it looks like as follows:

[Unit]
Description=Parrot products firmware loading daemon

[Service]
Restart=always
RestartSec=0
Environment=ULOG_LEVEL=D
Environment=FIRMWARED_VERBOSE_HOOK_SCRIPTS=y
ExecStart=/bin/firmwared

[Install]
WantedBy=multi-user.target

then, restart the firmwared service:
# systemctl daemon-reload
# systemctl restart firmwared.service

And post the output of journalctl while running sphinx.


#5

Hi, inside the data.zip file you have the journalctl, I have put it there because is a big one.

data.zip (6.0 KB)


#6

Hi,

I think the problem is your definition of the stolen_interface parameter inside your .drone file.

It should be <stolen_interface>wlxe84e06277173:eth0:192.168.42.1/24</stolen_interface> in your case and I suspect that the “eht0” part is missing from your .drone file.

Anyway, could you please post your .drone file just to be sure? Thanks

Regards


#7

I use both, the file and the command line. The file:

<?xml version="1.0" encoding="UTF-8"?>


<sdf_params
low_gpu=“false”
with_front_cam=“true”
with_hd_battery=“false”
with_flir=“false”
flir_pos=“tilted”/>
< pose>default< /pose>
< interface>eth1< /interface>
<wifi_channel>11</wifi_channel>

<stolen_interface>wlxe84e06277173:eth0:192.168.42.1/24</stolen_interface>

#######

And this is the command line:

sphinx /opt/parrot-sphinx/usr/share/sphinx/drones/bebop2.drone::stolen_interface=wlxe84e06277173::with_front_cam=false

Many Thanks!


#8

You don’t need to set the stolen interface parameter from the command line if it’s already present in the drone file. Here, the command line is overriding the .drone file value for the stolen interface parameter with an incorrect value (it is missing the :eth0:192.168.42.1/24 part).

Just remove the stolen_interface parameter from the command line and it should work.


#9

Excuse me, I didn’t make myself clear. I have try both, with and whitout parameters. Now I am calling to:
$ sphinx /opt/parrot-sphinx/usr/share/sphinx/drones/bebop2.drone

And I have in bebop2.drone:

<stolen_interface>wlxe84e06277173:eth0:192.168.42.1/24</stolen_interface>

And the wifi connection is still missing.

Here the new log:

log.zip (5.5 KB)


#10

The only way I manage to reproduce your problem is to change the ‘interface’ parameter in the .drone file you’ve posted to ‘eth0’ :

<sdf_params
low_gpu=“false”
with_front_cam=“true”
with_hd_battery=“false”
with_flir=“false”
flir_pos=“tilted”/>
<pose>default< /pose>
<interface>eth0< /interface>
<wifi_channel>11</wifi_channel>

<stolen_interface>wlxe84e06277173:eth0:192.168.42.1/24</stolen_interface>

In this case, the veth interface and the wifi interface name (‘eth0’) clash and I get the same error.

The interface parameter should be eth1
The stolen_interface parameter should be wlxe84e06277173:eth0:192.168.42.1/24.
Finally the command line should be :
sphinx /opt/parrot-sphinx/usr/share/sphinx/drones/bebop2.drone::with_front_cam=false

Could you please re-check your .drone file ?


#11

Yes! It work fine! Thank you very much!