Slamdunk_visualization crash


I’m just getting started with learning about ROS and the Parrot S.L.A.M Dunk. I’m working with Kubuntu 16.04. I was able to run rviz using the slamdunk_qsg.rviz presets. I built the slamdunk_ros packages to try the more advanced rviz configuration, but I ran into a crash:

$ rviz -d $(rospack find slamdunk_visualization)/rviz/slamdunk.rviz
[ INFO] [1488908018.992987280]: rviz version 1.12.4
[ INFO] [1488908018.993031791]: compiled against Qt version 5.5.1
[ INFO] [1488908018.993041557]: compiled against OGRE version 1.9.0 (Ghadamon)
[ INFO] [1488908019.145322241]: Stereo is NOT SUPPORTED
[ INFO] [1488908019.145395102]: OpenGl version: 3 (GLSL 1.3).
Segmentation fault (core dumped)

This may be a bug in rviz, but the crash actually happens when loading

#6  0x00007ffff7debbd9 in _dl_open (
    file=0x13dd5e0 "/home/vaughn/test/parrot_slamdunk/slamdunk_catkin_ws/devel/lib//", mode=-2147483391, 
    caller_dlopen=0x7ffff11fd862 <Poco::SharedLibraryImpl::loadImpl(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)+82>, nsid=-2, argc=<optimized out>, argv=<optimized out>, env=0x7fffffffdb78)

What should my next step be?


  • Vaughn


Turns out this is a known issue with running In Ubuntu 16.04 with Qt4. The solution was to build with Qt5:

catkin_make -DUseQt5=ON -j2


It’s a bit surprising it has compiled (cf. but it’s good the problem was solved.