Unknown Dongle Wifi


#1

Hello,
Actually, I’m trying to use the SLAMdunk as an access point. For this, I bought the TP-LINK TL-WN722N and EDUP EP-N1557.
For the first, it is not recognized. The second is recognized but the connection is very slow, there are packet losses and the key sometimes disconnects.
I think the problem comes from the drivers but currently I can’t install them because of the version of the kernel (3.10.40-g3590201). When I tried to compile the drivers, I have an error starting with “Error! Your kernel headers for kernel 3.10.40-g3590201 cannot be found.”. I tried to update my kernel with sudo apt-get install linux-headers-$(uname -r) but it doesn’t work.
Someone has an idea ?
Thank you for your answer,
Genjou


#2

We have successfully used the TP-LINK TL-WN722N, but it didn’t work at first. Here’s the trick: whatever USB-Wifi dongle you plug in first, that’s the one that the SLAM Dunk will use for its access point. We had previously plugged in a different type (Edimax), and the SLAM Dunk served up an access point as advertised. However, then we tried some other kinds (like the TP-LINK), and that didn’t work. What was happening was that the Edimax was being mapped to wlan0, and wlan0 was used by all the scripts that do the access point stuff. We did a search in the /etc/ folder for references to wlan0 and changed them to wlan2 (which is what the TP-LINK was showing up as), and that did the trick. So, either do that, or clear out old mappings so that the TP-LINK shows up as wlan0. Hopefully that will solve things for you.