ARDrone 2.0 SDK latest version

Hello,

I’ve recently got a ARDrone 2.0 and wanted to play with it. After a few hours, I’ve found the ARDrone 2.0 SDK and compiled it with success. Unfortunately, given examples with the SDK are not working (unrecognized tag, leading to seg fault + core dump). I tried to debug it but didn’t understand everything and no solution found right now.

However, from what I understood, this is due to the fact that the firmware of my drone has been updated and the given SDK is not the latest one and seems to be incompatible with the firmware. Downgrading the drone firmware is not a viable solution to me.

I’ve made some tests with the Android application (Freeflight 2.4.1) and everything worked like a charm. I also tried with a nodejs package (ar-drone) and it worked but something the drone was going crazy…

To conclude, I think the 2.0.1 is not the latest version of the SDK or not the one embedded into Freeflight 2.4.1. I would like to know if it is possible to get the source code (or the SDK documentation) of the latest SDK/Firmware (or the one shipped into Freeflight 2.4.1)? This is only for personal use (my goal is to control my drone from Raspberry PI Zero + USB controller).

Many thanks!

After searching, I’ve found that enabling demo data allows to run examples without any issue. But I’m not sure this is the way to use the SDK

I have been trying out the Android app ARdrone flight pro with my AR 2.0 thought I would give some results that I have found.
I have tried it with my original Google pixel phone and my Samsung Galaxy s6 active.

Ardrone flight pro works when connected to ar2.0 drone Wi-Fi and wired USB otg adapter connected to a Logitech f310 controller on Google pixel phone. I also tried the Google pixel phone with what turned out to be a clone PS3 controller “Shanwan” wired to a OTG adapter which did not work and I also tried it with the parrot flypad wired which would not work.

The flypad controller would initially work but after 30 seconds to a minute it would stop responding and be no movement on the screen of the controller.

The Samsung Galaxy s6 active however would only work wired with OTG to the clone PS3 controller and I also found I had to push the PlayStation button to start it up or it would not respond. I tried the Logitech f310 controller and also the flypad with the Samsung s6 but neither of these would work.

I also had a hard time getting the video and picture function to work and below what I found out.

Used plastic cruiser 32GB USB drive. to get USB drive recognized you have to plug battery in and let drone startup first and then plug drive in each time you want to use it. The lights on the drone will flash for a little bit and then turn solid green again. You should then see the time remaining on the disc show up on the screen if you have the on-screen display turned on for USB time remaining. Only video is recorded to USB drive pictures do not seem to be recorded to the drive. Recordings and pictures will not show up in the Google photos album you have to use a file app to locate them. When using with Google pixel phone the camera icon does not change when you push this and it does not make any sound but did record pictures to the phone in a different location than the gallery app.

I find it disheartening that two phones work completely differently with different controllers all I can think is maybe it has something to do with the version of Android they are running or maybe something else who knows.

This topic was automatically closed after 30 days. New replies are no longer allowed.