BebopDroneReceiveStream Socket Error


#1

Hi,

I successfully compiled the SDK, and then I modified the JS_IP_ADDRESS. But when I try to execute code in Samples, I got a error named “Socket access permission denied”. Does anybody know how to solve it?

Thanks.


#2

Hi,

Can you give us more information about what and why you modified ?
On which product are you trying to connect ?
Do you have any firewall on your computer ?

Thanks,
Djavan


#3

Thanks for your response.

I am sorry to find that it’s my mistake causing this problem.

But when I solved this problem and run the Samples for Bebop Drone in Ubuntu12.04, I got some outputs as follows:

It seems that something wrong for mplayer?

Could you help me?

Thanks.


#4

Hi,

I am having the same issue, how did you resolve the socket permissions error?

I am trying to connect to the Bebop Drone under Ubuntu 14.04

Thanks


#5

Hi,
do you have any solution? I think I have the same error (mplayer: could not connect to socket).

Thanks


#6

i think the socket error is not the problem. if you comment out the code to start the mplayer at this line:

execlp(“mplayer”, “mplayer”, "./video_ […]

and then start the BebopExample again and manually start the mplayer in another terminal you were able to see the video stream. maybe the problem is, that the “video out” to the video_fifo file is starting to late and mplayer quits.


#7

For your reference, in my env, this problem occurred due to the firewall.
I disabled ufw, and the problem is solved.