Development Environment for Airborne Night Drone


I’m trying to setup a Development Environment for Airborne Night Drone but I’m failing with simple bluetooth setup.
My Mac just does not SEE the drone at all so I can’t discover it. I have updated the drone to the latest firmware.
It works well on my mobile phone using Free Flight App. I can see the drone on the smartphone bluetooth discovery.
According to my Mac config I do support Bluetooth Low Energy. This is my Bluetooth hardware setup:
Apple Bluetooth Software Version: 4.4.6f1 17910
Hardware, Features, and Settings:
Name: User’s MacBook Pro
Address: 14-10-9F-DA-97-B6
Bluetooth Low Energy Supported: Yes
Handoff Supported: Yes
Instant Hot Spot Supported: Yes
Manufacturer: Broadcom
Transport: USB
Chipset: 20702A3
Firmware Version: v151 c5842
Bluetooth Power: Off
Discoverable: On
Connectable: Yes
Auto Seek Pointing: On
Remote wake: On
Vendor ID: 0x05AC
Product ID: 0x8286
HCI Version: 4.0 (0x6)
HCI Revision: 0x16D2
LMP Version: 4.0 (0x6)
LMP Subversion: 0x2297
Device Type (Major): Computer
Device Type (Complete): Mac Portable
Composite Class Of Device: 0x38010C
Device Class (Major): 0x01
Device Class (Minor): 0x03
Service Class: 0x1C0
Auto Seek Keyboard: On
Bluetooth File Transfer:
Folder other devices can browse: ~/Public
When receiving items: Prompt for each file
State: Disabled
Bluetooth File Exchange:
Folder for accepted items: /Users/user/Downloads
When other items are accepted: Ask
When receiving items: Prompt for each file
State: Disabled
Bluetooth Internet Sharing:
State: Disabled
Incoming Serial Ports:
RFCOMM Channel: 3
Requires Authentication: No

Any help will do! I have tried to reset my Mac, restart, remove all bluetooth config but nothing changes.

Thanks in Advance,

I think that I found a solution… please ignore for now.

I have tried to follow the instructions here:

I have installed the bluetooth explorer on my Mac and found the drone. I can connect to it from the explorer but I can’t get any sample project to connect to the drone.
The simple example from is unable to find the drone.
Is there a working SDK that can work on my Mac as well?

Thank you,

Where you able to solve this issue? I’m having the same problem.


A developer did a contribution to the sample in order to pilot the RollingSpider from a Mac. This sample is here.
It has been done a while ago so I’m not sure it still compiles, but you can see how it has been done. Also, you can try to directly contact the developer (Sean Weaver) if you have a question.

Best regards,

I’m moving forward with this but now I’m having these errors after starting the controller device.

[ERR] ARDISCOVERY_Device | 11:00:33:354 | ARDISCOVERY_Device_NewARNetworkAL:243 - error: Unknown generic error
[ERR] ARCONTROLLER_Network | 11:00:33:354 | ARCONTROLLER_Network_New:303 - error: Network type, not available for the platform error
[ERR] ARCONTROLLER_Network | 11:00:33:354 | ARCONTROLLER_Network_New:337 - error: Error during the getting of the ARNETWORKAL_Manager from the device
[INF] ARCONTROLLER_Device | 11:00:33:354 | ARCONTROLLER_Device_StartRun:5079 - Start failed or canceled.

My guess is that it isn’t that the network isn’t available, but something else is missing in my code. I will keep looking into this but a little help will be appreciated.