Downgrading the AR 2.0 firmware

For academic research purposes, I am trying to control AR 2.0 through ROS (ardrone_autonomy package). However, it seems that I need to downgrade the firmware from 2.4.8 to an older version (2.0.16, for example). I did not seem to find any documentation on that. I only found this link (How to downgrade from 2.1.20 to 2.1.16 - drone-forum.com). But that did not work as well.

I really appreciate any help you can provide.