Installing SDK 2.0.1 problem


#1

Hi,

I’ve just bought an AR 2 drone for video developing purposes.

I’m trying to install de SDK in my UBUNTU 15.10 computer, but I got this error

ld common/mobile_main
/usr/bin/ld: …/…/Soft/Build/targets_versions/ffmpeg_static_PROD_MODE_Linux_4.2.0-23-generic_GNU_Linux_usrbingcc_5.2.1/libavutil.a(eval.o): not defined symbol reference 'fabs@@GLIBC_2.2.5
/lib/x86_64-linux-gnu/libm.so.6: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
generic.makefile:136: recipe for target ‘/home/xxx/ARDrone_SDK_2_0_1/ARDrone_SDK_2_0_1/Examples/Linux/Navigation/Build/…/…/Build/Release/common/mobile_main’ failed
make[4]: *** [/home/xxx/ARDrone_SDK_2_0_1/ARDrone_SDK_2_0_1/Examples/Linux/Navigation/Build/…/…/Build/Release/common/mobile_main] Error 1
app.makefile:33: recipe for target ‘all’ failed

Could anyone help me?

Thanks in advance.

Javier


#2

ok ok …

There is no further development on this sdk and it’s not working on linux x64 systems …

thanks


#3

Humm, nice to know. Been having the same problem myself.

What do we do instead?


#4

You can install a 32 bit system.
This SDK is no longer supported


#5

So there is no new SDK used for Ar.drone 2.0? This is what we got right?

Guess 32-bits linux is the solution then.


#6

There is no need for a new SDK, as the 2.0.1 is perfectly working :slight_smile:


ARDrone SDK 2.0.1 - Problem compiling the sdk_demo example
#7

Ok. I just installed Debian i686 (32-bits) … I still get the samme error I did on x86_64 linux -> http://pastebin.com/jw6UJkXQ

I also tried running ARDrone_SDK_2_0_1/ARDroneLib/Soft/Build/check_dependencies.sh, but I get this errormessage: “make: *** check_dependencies.sh/FFMPEG: Not a directory. Stop.”


ARDrone SDK 2.0.1 - Problem compiling the sdk_demo example
#8

Found the solution. This fixed it:

“I am not quite sure, but I guess you could follow these steps:1) In the Terminal application run the following six commands:
Code:
sudo apt-get install libgtk2.0-dev
sudo apt-get install libsdl1.2-dev
sudo apt-get install libiw-dev
sudo apt-get install libxml2-dev
sudo apt-get install libudev-dev
sudo apt-get install libncurses5-dev libncursesw5-dev2) Set “USE_LINUX=yes” in “ARDronelib/Soft/Build/custom.makefile”.*
3) In the Terminal application go to the “ARDroneLib/Soft/Build/” folder and run make
4) Open the ARDronelib/Examples/Linux/video_demo/Build/Makefile.
Add to GENERIC_LIBS in line 47 -lm -lgobject-2.0 -lgdk-x11-2.0
So that it looked like a
GENERIC_LIBS=-lpc_ardrone -lrt -lgtk-x11-2.0 -lcairo -lgobject-2.0 -lgdk-x11-2.0 -lm
5) In ARDronelib/Examples/Linux/Navigation/Makefile add -lm to GENERIC_LIBS
6) Navigate to the ARDronelib/Examples/Linux. Run make”

Thanks to Fizuli Valizada @ http://gauth.fr/2011/09/introduction-to-the-ar-drone-sdk/


#9

hi every body
i have x64_Ubuntu 14 and ARdrone2.0
u said SDK 2.0.1 working good in x64 systems
but i have problem when i want to make examples
error adding symbols: DSO missing from command line
i installed all necessary lib s and …
i m confused … why running a sample should be that much hard???


#10

hello again
i solved my problem with making sdk 2.0.1 on ubuntu 64 bit OS

Add the following statement to the 159th line (or above) of “Makefile”, which is located in the “Examples/Linux/Navigation/Build/” folder.
CODE: SELECT ALL
GENERIC_LIBS+= -lm