New firmware 4.2.0


#1

Hello there,
has this new firmware the camera velocity tilt?
Thank you?


#2

Hi,

Yes it should. CameraOrientationV2 also.
Regards,
Djavan


#3

You mean deviceController->aRDrone3->setCameraVelocity ?


#4

@Djavan do you think the camera velocity will be available for Bebop 1?
A lot of my customers are asking this think!
Thank you!


#5

Yes I meant deviceController->aRDrone3->setCameraVelocity and deviceController->aRDrone3->setCameraOrientationV2 (which pass the orientation with a floating point value).

These two commands will certainly be implemented in the next Bebop 1 firmware release.


#6

Thank you good news for Bebop 1 users!


#7

I have tried the setCameraOrientationV2 function and get the following issue

    sleep(1);
    [_bebopDrone setCameraTiltAngle:-40];        
    sleep(2);
    [_bebopDrone setCameraTiltAngle:0];
    sleep(2);
    [_bebopDrone setCameraTiltAngle:0];
    sleep(2);
    [_bebopDrone setCameraTiltAngle:0];
    sleep(2);
    [_bebopDrone setCameraTiltAngle:0];
    sleep(2);
    [_bebopDrone setCameraTiltAngle:0];

-(void)setCameraTiltAngle:(float)tiltAngle {
    if (_deviceController &&(_connectionState == ARCONTROLLER_DEVICE_STATE_RUNNING)){
        _deviceController->aRDrone3->setCameraOrientationV2(_deviceController->aRDrone3,tiltAngle,0);
    }
}

But the camera is moving up a little bit every time when the same setCameraTiltAngle gets called!

Is this a firmware issue or I am not using the setCameraOrientationV2 function correctly? @Djavan


#8

Hi @Shironalove,

Could you please give us the details about your drone and its firmware version?
Could you also explain what you’d expect and what you get, I don’t really understand what you mean by [quote=“Shironalove, post:7, topic:6058”]
every time when the same setCameraTiltAngle gets called
[/quote]

Thanks in advance,
Djavan


#9

I have two Parrot Bebop 2 drones. The firmware is 4.2.0 for both.

I expect

setCameraTiltAngle:0

gets called, and the drone camera will move to 0 degree and then no matter how many times the same function gets called, it should stays at degree 0. However, actually the drone camera moves up a little bit every time the same

setCameraTiltAngle:0

gets called. I tried with my other Bebop 2 as well. Same weird result.

I think when I use the same function in firmware 4.0.5, the camera angle is respond correctly to my command. So I guess it is the firmware that cause this change. Would you kindly explain this behavior or if you can repeat the experiment on your Bebop 2 with firmware 4.2.0 and see if it has this problem. Thank you in advance!


#10

sendCameraOrientationV2 will work on older firmware? i mean will be taken as sendCameraOrientation (not V2),will crash or will be just ignored and the camera don’t move? i mean i have to check the current firmware version before use it?


#11

@Shironalove:
I don’t see this behaviour. If I set -40, wait for 2 seconds, set 0 wait for 2 seconds and set again 0, the camera won’t move. In fact, when you set a value, it will send it periodically to the drone (same as the PCMD). So setting again and again 0 does nothing.
What you might see is the camera tilt no moving immediately to the value you gave. This is because the drone is smoothing the camera orientation. So you have to wait for a small amount of time for the orientation to be the one you asked.
Don’t forget that you can see the actual orientation thank to the dedicated event.

@mitch: Using the V2 will work on older firmware version because we implemented a way to copy the values from the V2 to the deprecated V1 (In the V1, the floating point accuracy is lost of course).


#12

I came across this trouble again today and have the event listener on and here is the output:

in ViewDidAppear:

setCameraTiltAngle: -15

and result:

current tilt: -15.358758

in the algorithm:

setCameraTiltAngle: 0

and it is constantly printing out:

current tilt: -10.277211

feels like this camera operation is never finished somehow!

If I tap again to send the command:

setCameraTiltAngle: 0

and it is constantly printing out:

current tilt: -7.051639

also printing out that forever

After I send

setCameraTiltAngle: 0

about 20 times, it finally arrives at -0.00000

but still printing out that indefinitely.

How can I solve this problem? I tried with all three Bebop 2 drones, and they all gave me the same result, so I am quite sure it is not the hardware this time.

Also, I am working on Xcode 9 beta, when I download the new SDKSample from GitHub, it won’t compile and run. I don’t know if this is going to be a problem with newer SDK. But I do realize that the newer Xcode example is with

LATEST_SDK_VERSION='3.12.6'
SDK_PACKET_NAME='ARSDK3_iOS_3_12_6.zip'
SDK_DOWNLOAD_ADDRESS="https://github.com/Parrot-Developers/arsdk_manifests/releases/download/ARSDK3_version_3_12_6/$SDK_PACKET_NAME"

while my current version script is

LATEST_SDK_VERSION='3.11.0'
SDK_PACKET_NAME='ARSDK3_iOS_3_11_0.zip'
SDK_DOWNLOAD_ADDRESS="https://github.com/Parrot-Developers/arsdk_manifests/releases/download/ARSDK3_version_3_11_0/$SDK_PACKET_NAME"

Do you think that is the reason for this weird behavior?


#13

Hi,

Your problem seems to be the same as the one in this topic. Upgrading to 3.12.6 SDK should solve the issue :wink:

Regards,
Nicolas.


#14

Thanks. I switch to 3.12.6 but with the scheme

DebugWithPrecompiledSDK

but Xcode is complaining about

'libARController/ARController.h' file not found

I am using CocoaPods with the SDK, is there anything else I have to do before running with this new SDK?


#15

This might be due to the fact that we changed the name of the folder containing the SDK libraries.
What you should do is explained in the 3.12.4 release changelog.