Noob needs help

Hi All

I could really use some help. I have a Rpi B+. Mini BLE usb adapter & 4GB SD card.
I downloaded the Raspbian Jessie Lite image with 4.1 kernel from the Rpi website.

I followed the instructions on https://github.com/Parrot-Developers/FlowerPower-Tools/tree/master/BLE-cloud-bridge

After installing NodeJs, I get an error when running node --version. The error is Segmentation fault

Also after installing the Bluetooth binaries, I can detect the USB adapter

hci0: Type: BR/EDR Bus: USB
BD Address: 00:1B:10:00:2A:EC ACL MTU: 1017:8 SCO MTU: 64:0
UP RUNNING
RX bytes:972 acl:0 sco:0 events:39 errors:0
TX bytes:402 acl:0 sco:0 commands:39 errors:0

However when running sudo hcitool lescan I also get an error. Set scan parameters failed: Input/output error

Can anyone give me the instructions from Which OS to use, then what next.

Also the instructions on the link above do not list installing npm, however the license files goes through this step.

Many Thanks
Sam

Hi @slees78

Try to delete node and following this:
$ wget http://node-arm.herokuapp.com/node_latest_armhf.deb $ sudo dpkg -i node_latest_armhf.deb
node --version should be 4.2.1

Bruno

Thank you Bruno.

Next silly question. How do I delete the node ?

Sam

Try sudo apt-get remove nodejs

Thank you Bruno. This worked and I have a functioning version of Node running.

1 Like

Hi All

I really need detailed instructions. I am upto

Step 3: Build the brigde

Now, if Nodejs and BLE libraries are installed, clone this repository and do:

$ ./configure

What to I clone and where do I clone it to ? When do I use the code that is posted on this site, and where do I save this to ?

I.e. When do I build the DB ?

Where do I get my :

"client_id": "...",
"client_secret": "...",

I really want to get this up and running,

Regards
Sam.

Hi @slees78

Get your access API

  • username password
  • client_id client_secret
    • Sign up to API here, and got by email your Access ID (client_id) and your Access secret (client_secret).

https://github.com/Parrot-Developers/node-flower-bridge/commit/ba2aa4354a6af5c66a59d7b68272ed330cd7b325

And now, I will update this program here: node-flower-bridge

Bruno

Thanks, I have found the new program. I was stuck with the “Clone the libraries”, and I am not sure I have done this correctly. I downloaded it to my laptop, unzipped, and then copied it to the “home” folder of my Rpi (minus one level of folder).

/pi/node-flower-bridge-master/

I have updated the credentials, and now trying to run the program with ./run display

I receive “permission denied”. when I try sudo ./run display, I get “command not found”

Thank you for your help and patience
Sam

Don’t worry :wink:
How do you interact with you raspberry?

Be in relation with your rasbpy

From your rasbpy (Keyboard + Mouse + Screen)

  • Open a terminal

From your laptop (Ssh)

  • $ ssh pi@X.X.X.X

Get the program

  • $ git clone https://github.com/Parrot-Developers/node-flower-bridge
  • $ cd node-flower-bridge
  • $ npm install
  • Edit credentials.json

Run it

  • $ ./run display

Bruno

Bash run worked in the end.

Thank you for all your help.

I use a remote connection via ssh. If I used $ bash run display 60, and close ssh. The next time I log in, how can I check the status of the running process?

Thanks
Sam

ps -aux | grep start.js

1 Like

Thank @elitistphoenix

I updated the script to show the status simply $ ./bridge status:

Pull the repo :slightly_smiling:

Bruno