Parrot Mambo - Python


#61

Glad to hear it’s not just us! It’s a shame as we went the Mambo/FPV over the AR for the WiFi connectivity.

It’s a bit hectic trying to get 20x 14yr olds connected to their drone, and doing something meaningful in 50 minutes! Love to hear about any updates that Parrot may release for this issue.


#62

Hey @CaptainSaavik - Has Parrot released any fix for the wifi connectivity issues?

Many thanks :slight_smile:


#63

That’s a question for @Jerome or @Nicolas


#64

Thanks @CaptainSaavik

@Jerome or @Nicolas - Is there any update with this?


#65

We actually had lots of trouble in BLE when removing battery/disconnecting improperly on iOS.
I am not aware of any wifi issue.


#66

Thanks for the reply @Jerome - really appreciate it and I’m looking forward to getting to the bottom of it.

In Windows and Debian, I’m having trouble reliably connecting to drones via wifi. I’ll get some more diagnostics over the weekend to give you a better picture of what I’m experiencing.


#67

Hey @CaptainSaavik :slight_smile: Thank you again for all your work with this project!

I’ve given the latest commit a go on my home setup: Windows x64 with a Mambo FPV. I’m hoping you can help me with a couple of things I am struggling with:

mambo.ask_for_state_update() gives me:

e[38;5;196m Could not find sensor in list - ignoring for now.  Packet info below. e[0m`(2, 25, 3)`
e[38;5;196m Could not find sensor in list - ignoring for now.  Packet info below. e[0m
(2, 25, 5)

Also, I’m not having any luck with the new demoMamboVisionGUI.py file

Traceback (most recent call last):
  File "C:\Users\Scott\Desktop\testing\pyparrot-master\demoMamboVisionGUI.py", line 6, in <module>
    from DroneVisionGUI import DroneVisionGUI
  File "C:\Users\Scott\Desktop\testing\pyparrot-master\DroneVisionGUI.py", line 24, in <module>
    import utils.vlc as vlc
  File "C:\Users\Scott\Desktop\testing\pyparrot-master\utils\vlc.py", line 203, in <module>
    dll, plugin_path  = find_lib()
  File "C:\Users\Scott\Desktop\testing\pyparrot-master\utils\vlc.py", line 173, in find_lib
    dll = ctypes.CDLL(libname)
  File "C:\Program Files (x86)\Python36-32\lib\ctypes\__init__.py", line 348, in __init__
    self._handle = _dlopen(self._name, mode)
OSError: [WinError 126] The specified module could not be found

Also, when running demoMamboVision.py I get the following errors. I ran it 3 times and included the output in the file below. I also restarted the drone and it gets the same result after a restart too.

Thank you for all your patience!


#68

For the missing sensors, don’t worry about those. It’s on my long term list to fix but they are not important ones.

For the GUI vision, I promise to write up the documentation on that as soon as this semester ends. In the meantime, that code isn’t officially released yet :slight_smile: but you are missing VLC. Install the VLC executable of at least version 3.0.1 or greater.

Also, put bug reports for pyparrot on the GitHub for pyparrot rather than here :slight_smile:


#69

We had our class out with the Mambo’s today. They all connected via WiFi and worked fine… until they didn’t. It seems like once they disconnect you have little chance of getting them to reconnect (i.e. after a crash, or code-hang or after a battery pull/replacement).


#70

I have observed this behavior as well. We had to switch drones to get it working.


#71

Hey @CaptainSaavik and co :slight_smile:

Has anyone had success using a virtual environment? I’m trying to get it running tonight on a Windows 10 host with vmware player + ubuntu.

I can connect to the drone fine (wifi), however, after take off the drone times out. Not sure if it’s an issue on my end or if it’s observed with all virtual environments. If others have success in a vm I’ll dig deeper :slight_smile:


#72

I was not able to make a virtual environment work for BLE. I have tried windows a few times in a VM (I have a Mac) just for debugging purposes and it has always been fine. So you are running windows as the host OS and then trying to run linux VM? Why not just use windows? It works fine in all OS’s using wifi.


#73

I was running Linux because it seems like it ‘just works’ better (perhaps it runs better too?)

Our students have 1:1 Windows Laptops that are reasonably locked down in our school environment. I was going to use an Ubuntu VM, however, getting time-out issues. Previously we had loaded Ubuntu on a USB but it’s pretty temperamental with file system issues - perhaps dodgy USBs. I was hoping a VM might be a nicer experience for our students, and it also allows them to access their native OS :slight_smile:

I would go native Windows, however, the lack of Bluetooth + the need to install a pretty hefty C++ tools for zeroconf makes it tricky.


#74

Btw, you might move this over to the pyparrot GitHub issues list. Rather than the developer forum here.

But are the sys admins not allowing the installs on windows itself? I know the C++ tools are hefty but they work…


#75

Will do - I wasn’t sure if it was an issue specific to PyParrot or a VM environment in general.

Our student’s laptops have some pretty heavy restrictions, unfortunately. Windows is also a bit more fiddly in terms of getting ffmpeg, openCV etc all set up. With 50 minute lessons it’s just easier giving students a VM image and away they go.

The good news is that it seems like zeroconf no longer needs C++? Or at least Pip isn’t complaining about not having it installed any more?


#76

sletts021,
Not usre if you have recivce a reply yet? If not check out this link: https://github.com/amymcgovern/pyparrot,

I am still getting up to speed but have been able to get my parrot mambo FPV up and fly/crashing via the code and windows 10 lap top. When you are able to start to use the examples - they need a bit of space.

best of luck.