Parrot Sequoia with mac


I am working on a school project that involves working with the parrot sequoia. I want to control this camera using Python however I am unable to do so. I try the following GitHub and I ran this code
“from ptpy import PTPy
camera = PTPy()”

I got the same error as: Sequoia not visible as PTP device on Ubuntu

The solution says to unmount the Sequoia as a mass storage device, however it doesn’t even appear to be connected to my mac.

@jcfarsight can you possibly help?

@nsp Unfortunately I no longer have my Sequoia to assist with troubleshooting. The only suggestion I can give is perhaps trying it on another machine, or continue digging to see if something else on your machine is claiming the USB device (it may not be mass storage).

@jcfarsight No worries. Thanks.
Just a follow-up from your previous post. What did you mean by "unmounting the Sequoia as a mass storage device " as in just unplugging the USB?

Have a look at the ‘unmounting the drive’ section. Basically you need to do the equivalent of safely disconnecting the Parrot as if it was a USB drive.

This topic was automatically closed after 30 days. New replies are no longer allowed.