Running simulations in Sphinx on Bebop2 with native and Android sdks


Hi all,

I’m trying to compile sdk on native and android versions, and trying to connect to the sphinx.
I ran into errors, unable to go beyond the sample Bebop on ubuntu, stuck after the mplayer opening up and the connecting… screen.

So, I’ve now switched to the android app sdk sample, and it gives libcurl errors, as the libcurl library is missing from the source, and the compiling fails.

My priority is getting the SDK to build and connect the Bebop sample to the sphinx,

  1. Can I connect it to sphinx on the same system? if so, how?
  2. Will I need two separate machines to connect it to the sphinx?

Product: [Bebop2]
Product version: [X.X.X]
SDK version: [X.X.X]
Use of libARController: [YES/NO] (Only for ARSDK)
SDK platform: [iOS/Android/Unix/Python…]
Reproductible with the official app: [YES/NO/Not tried]


Hi Samt,

Did you manage to solve this issue? I’m having the same problem and I don’t know whether two separate machines are required or only one computer is enough. If you or anybody else know how to fix this, please let us know.

Best regards!


I tried with Ubuntu running in a VM with bridged networking on a host OSX machine and eventually gave up. I tried various USB networking adapters / etc and never got it to work.

If someone has it working, it is likely on a physical Ubuntu host using the exact hardware Parrot recommends.

The compile errors you guys are having are unrelated.


Hi Synman,

I manage to make it work (in Ubuntu 16.04 with no VM), but I had to do a few settings:

  • First of all, you have to be sure that the BebopSample has the correct IP. So, you have to modify the code in order to use it in the same machine (in my case) as a Virtual Ethernet network:
    //#define BEBOP_IP_ADDRESS “”
    #define BEBOP_IP_ADDRESS “”
  • After that you should build again the demos of the SDK.
  • Then, in your case, probably you should set manually an IP in the same network as simulator and drone. In your VM probably you have an IP address by default that is not in the same network, so they can’t see each other.
  • Once everything is set, the next step should be launching the Sphinx in one machine (local or virtual) and then the BebopSample demo in the other one (local or virtual).
  • Even though it’s pretty obvious, if you launch the demo with a Bebop then select 1 in the demo, but in case it’s Bebop2 select 2. Otherwise it won’t work.

I hope this can help you.

Kind regards!


You can override the IP address when setting up the device controller. At least you used to be able to. Hmm.



I am sorry for this late reply, I am just seeing this thread.
I would probably have seen it sooner if it were in the Sphinx category.

Note that there the simulated drone is always reachable at from the Sphinx host. The WiFi access point is entirely optional. The .drone file samples that are installed by Sphinx also define a WiFi access point for the simulated drone (see the Sphinx documentation for drone file stolen_interface parameter). If you don’t want to create an AP (or don’t have an available wifi interface on this machine) you simply need to remove the “stolen_interface” parameter from the .drone file and the simulated drone will still be reachable at

sento86 is right, you probably need to modify the sdk Bebop sample with the correct IP address and, if Sphinx is running inside a VM or on a remote machine, ensure that the simulated drone is reachable at this address from your controller. In this case, this also means you need to root the traffic from the VM/remote and forward it to on the Sphinx machine.



Hi Nicolas, sorry to bother maybe you know what I am asking about how to integrate SDK and my custom code with the Simulator, here I created a topic, thanks for your time,