Samples get to "Connecting ...", then close


Hello, I’ve followed the installation guide and put the SDK on my Bash (64 bit, corresponds to Ubuntu 16.04) on Windows. My partner additionally put the SDK on his regularly booted Ubuntu and we came upon the same exact error. I run the sample, the mplayer pops up, the terminal says “Connecting …”, then it closes and I just have “[INF] JumpingSumoSample | 19:00:19:616 | main:152 - – Jumping Sumo Sample --” to show for it. It’s the same thing for “BebopSample”.

I’m attaching a picture. Please pardon the part where I forgot to run Xming. It’s the end of the messages for building the samples at the top, then running the sample, then some system info.

The two other issues I’ve noticed and not been able to resolve are a “Failed to execute command” for something involving alchemy, and “BebopSample is not enabled in the config”. Those are the only other things that have caught my eyes.

Additionally, I would have thought, oh it’s just a connection problem, but I was able to connect to the drone and start the motors with no problem with “node-bebop” (

tldr; Can’t get the SDK samples to actually run but I can connect to the drone with someone else’s package. I suspect a missed a step in the install. Any thoughts?

Product: [Bebop/Bebop2]
Product version: [X.X.X]
SDK version: [X.X.X]
Use of libARController: [YES/NO] (Only for ARSDK)
SDK platform: Unix
Reproductible with the official app: [YES/NO/Not tried]