Skycontroller 2 - Wifi and HDMI out


Ah - the mention of the apple usb-ethernet cable compatibility is great, I thought that was discontinued as it was so slow. - I will buy one tomorrow and test. thx.
Looking forward to the fun surprises for the 1.0.5 version - one of the best ones would be to have higher quality video streaming out of SC2 at e.g. 720p or 1080p :wink:


You can already have a 720p video stream !

There is the SetVideoResolution command, which allows you to toggle between the “normal” 1080p recording + 480p streaming, and a 720p recording + 720p streaming mode.
The encoder can not handle one 1080p record + a 720p stream at the same time, so increasing the streaming resolution has to reduce the record resolution.

Please note that the “streamed” 720p il still at a lower quality (both in h.264 profile and bandwidth) than the recorded one, but it will be better than the 480p :wink:

FYI, this mode is enabled by FreeFlight when using the Cockpit Glasses, to improve the FPV experience.



Hello dear developers and skilled people.

can you help me, how to stream the live video of BEBOP2 to an other device, like other tablet or notebook (then with notebook I will be able to project it with a projector)

now I use bebop2, with android (6) device.

I use as a range extender a TP-link TL-WA830RE.

in the case I use range extender, I set the range extender to “extend” the bebop2 range, then I connect with phone to the range extender too.

so it is… BEBOP2 -------range extender--------phone.

I also got a new skycontroller2 from my friend, for testing (sadly his bebop2 fell into a lake :frowning: )

what would be my options when I use only skycontroller2, in that case of course no TP link range extender? (to get to the video stream?)

and also, I do not really understand the way skycontroller 2 works.

“in the case I wanted” to use range extender and the skycontroller 2 simultaneously, how ould I do that? I do not see any wifi of the skycontroller2.

thx for your answers.



Hi Nicolas
I just got back into Parrot flying with some Disco Agri gigs.

I have two specific questions:
a) On my iphone it says my Skycontroller 2 is ‘up-to-date’ with 1.0.4, but there must be a 1.0.5 version - in the developer forums and your API documentation, you say that 1.0.5 is released and available.

So how can I update my Skycontroller2 to v1.0.5?

b) I connected a usb/ethernet cable to my Skycontroller2 ( and can stream from BEBOP2 and Skycontroller2 to vlc or to ffmpeg with this setting in sdp:
c=IN IP4

m=video 55004 RTP/AVP 96·

a=rtpmap:96 H264/90000

c) HOWEVER, when I try the same with my Disco drone, ffmpeg does not receive any stream? I know Disco is not 'offical supported in the SDK yet - however the video must come through some ip/port - which one is it?

I tried and 55004, but this does not pick up any stream either.

What can I do to stream video from SC2 via usb/Ethernet from Disco like I do with Bebop2? What is the difference?

One last note: My ethernet/usb cable is good, as I can ping and I get packets back.
This address you suggested for commencing Disco stream via ethernet and VLC does however not work either

Must be some setting of IP or port for Disco?
Thanks so much for your help


So I’ve just purchased the Parrot Disco, and I would like to have some kind of stream available while I’m flying, maybe to a TV, so other’s can see as well.
Considering what’s written in this thread, is this possible? Is this about connecting an USB ethernet adapter to Skycontroller 2, and then through an RTP client show the video on a computer?
But how about the iPad/iPhone you’re supposed to fly with…? It’s not possible to do both?
I guess USB hub won’t work?..or…?

How about Apple Ethernet adapter -> Wireless AP -> Multiple WLAN RTP clients?
I’d like one to be a tablet (preferably iPad) I fly from, another could be Kodi or VLC connected to the TV (or can AppleTV read RTP URLs?)



I have a Skycontroller 2 from Parrot disco and want to connect it to my PC to get the video feed on a large display so I bought Dlink DUB-E100 USB2ETHERNET adapter as was suggested here.

I connect it to usb port in Skycontroller 2 and nothing happens, the adapter just doesn’t start up at all, the link led is off… :frowning:

I tried to connect adapter to PC to ensure it is not damaged - and all was fine - virtual adapter appeared and connection was established. So the adapter hardware is working fine.

What am I doing wrong? Please help)



Guys, I solved my problem, buying another usb2ethernet stick - BITES USB 2.0 LAN.
So i succesfully caught stream in VLC player but with about 330ms delay. The quality of streaming is good.

To decrease the latency I tried to view the stream with gstreamer like this:

gst-launch-1.0 -v -e udpsrc port=55004 ! “application/x-rtp, media=(string)video, clock-rate=(int)90000, encoding-name=(string)H264, framerate=24/1” ! rtph264depay ! decodebin ! videoconvert ! autovideosink sync=false

I get the video feed, it is with almost no delay, but it is very glitchy and pixelized, looks like some stream parameters are not synchronized… Maybe someone tried to get the video with gstreamer?