Sudo diagnostic


The following is the output of sudo diagnostic. As one can see, linux-sanity, magnetometer, barometer, codec, ultrasound are ko and no topic is echoed. How to solve this issue?

01-linux-version ok [system] Linux version
02-memory ok [system] Memory close to 2GB
03-linux-thermal ok [system] Linux thermal zones availability
04-cpu-governor ok [system] CPU governor
05-linux-sanity ko [system] Linux sanity
20-magnetometer ko [sensors/i2c] Dev ID of AK8963C magn on /dev/i2c-0 (Result: 0x0f)
21-barometer ko [sensors/i2c] Ping MS5607 barometer on /dev/i2c-0
22-codec ko [sensors/i2c] Ping ADAU1772 codec on /dev/i2c-0
25-ultrasound ko [ultrasound] Ultrasound Result: KO Distances: ""
30-camera ok [camera] Cameras acquisition
31-camera-freq ok [camera] Frequency Result: 33.200 ms (33.33 ms) diff=0.39%
32-camera-conn ok [camera] Camera connection: Left is OK and Right OK
40-imu ok [imu] IMU Result: 15911 lines (16000) diff=0.56 %



I have the same problem since Friday with linux-sanity and ultrasound.
I also have no topic echoed.
Did you find a solution ?

Thank you


Unfortunately no! Is it the ultrasound sensor only which is not working for you??



When I wrote my message last week, the ultrasound sensor was the only topic that was not working.
However today all my sensors are working, but linux-sanity is not…

I can’t echo topics.

I tried an update but it did not change anything.



Actually it is true, sometimes (if not all the time) all the stuff except linux sanity is ok and still nothing happens and an update does not help as well. I am not sure if you have already tried this but try keeping a lot of decor and keep the place where you are using your sensor well lit, may be it will start working. But I must confess, this is the most unpredictable and inconsistent device I have ever seen and what makes things worse is the poor customer service. I hope some customer service engineer reads this and responds!!!

Ultrasound topic

I did an update, everything was working, but 2 days ago it stopped working correctly

When I do sudo diagnostic -v, I have
slamdunk@slamdunk-000344:/dev$ sudo diagnostic -v
[sudo] password for slamdunk:
Running /etc/diagnostic.d/01-linux-version.diag…
01-linux-version ok [system] Linux version
Running /etc/diagnostic.d/02-memory.diag…
02-memory ok [system] Memory close to 2GB
Running /etc/diagnostic.d/03-linux-thermal.diag…
03-linux-thermal ok [system] Linux thermal zones availability
Running /etc/diagnostic.d/04-cpu-governor.diag…
04-cpu-governor ok [system] CPU governor
Running /etc/diagnostic.d/05-linux-sanity.diag…
05-linux-sanity ko [system] Linux sanity
Running /etc/diagnostic.d/20-magnetometer.diag…
20-magnetometer ko [sensors/i2c] Dev ID of AK8963C magn on /dev/i2c-0 (Result: 0x0f)
Running /etc/diagnostic.d/21-barometer.diag…
reading 0x77-0xa2: 0x9c 0xb0
21-barometer ko [sensors/i2c] Ping MS5607 barometer on /dev/i2c-0
Running /etc/diagnostic.d/22-codec.diag…
reading 0x3f-0x0: 0x17
22-codec ok [sensors/i2c] Ping ADAU1772 codec on /dev/i2c-0
Running /etc/diagnostic.d/25-ultrasound.diag…
25-ultrasound ok [ultrasound] Ultrasound Result: KO Distances: "3.065 1.955 1.588 "
Running /etc/diagnostic.d/30-camera.diag…
30-camera ko [camera] Cameras acquisition
Running /etc/diagnostic.d/31-camera-freq.diag…
31-camera-freq ko [camera] Frequency Result: ms (33.33 ms) diff=-inf%
Running /etc/diagnostic.d/32-camera-conn.diag…
Sensor detection done.
Open sensor 0
Machine: kalamos

Jetson-TK1: No
AR0330 **** Can not open camera device: Device or resource busy
NvOdmImagerOpenExpanded 462: Sensor ERR
NvOdmImagerOpenExpanded FAILED!
error: cannot open stereo: no imager connected
32-camera-conn ko [camera] Camera connection: Left is unknown and Right unknown
Running /etc/diagnostic.d/40-imu.diag…
40-imu ok [imu] IMU Result: 52 lines (16000) diff=99.67 %

Do you know how to correct it ?
Thank you



Sorry, I really don’t know how to solve this issue. I gave up on parrot and stopped using the device. Terrible service!


Hello subodh514,

I have some news for you.
Nothing was working, until today !
Even if the sudo diagnostic command indicates that all the sensors are ko, I can listen to the topics, something I could not do yesterday !

I just launch the command “sudo ntpdate” while the SLAMdunk being connected with an ethernet wire.

Can you try this, reboot, wait a bit (something like 2 hours, I don’t know why but it was not working on the first try for me), and check if you can listen to some topics ?


In fact it worked for 10 minutes …