The command to build the SDK for Android platform throws error


#1

OS: Ubuntu
Product: [Bebop/Bebop2]
Product version: [X.X.X]
SDK version: [X.X.X]
Use of libARController: [YES/NO] (Only for ARSDK)
SDK platform: [iOS/Android/Unix/Python…]
Reproductible with the official app: [YES/NO/Not tried]

When I’m trying to build the SDK for Android platform with command ./build.sh -p arsdk-android -t build-sdk -j, I get the following error:

make_standalone_toolchain.py: error: unrecognized arguments: --deprecated-headers
ls: cannot access ‘/home/mikkita/out/arsdk-android/armeabi/toolchain/bin/*-objdump’: No such file or directory
/home/mikkita/build/alchemy/toolchains/linux/bionic/selection.mk:103: *** Failed to detect android toolchain prefix. Stop.
[E] Task ‘build-common-armeabi’ failed (Command failed (returncode=2))
What should I do to fix this error?
I have Android studio installed (in /usr/local/android-studio ) with sdk, ndk, cmake and LLDB in default folders


#2

Hi,

The SDK requires the r15c version of the Android NDK. You have to download it manually from the NDK website, as the one provided with Android Studio is too recent.
Please see this answer for more details.

Regards,
Nicolas.


#3

Nicolas, thank you for the answer. Your solution worked.