Trying new node-flower-bridge

Hi,
When trying the new https://github.com/Parrot-Developers/node-flower-bridge I get an error:

pi@raspberrypi ~/node-flower-bridge $ ./bridge display

– Flower Bridge –

module.js:339
throw err;
^

Error: Cannot find module 'd’
at Function.Module._resolveFilename (module.js:337:15)
at Function.Module._load (module.js:287:25)
at Module.require (module.js:366:17)
at require (module.js:385:17)
at Object. (/home/pi/node-flower-bridge/node_modules/cli-color/index.js:3:9)
at Module._compile (module.js:435:26)
at Object.Module._extensions…js (module.js:442:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:311:12)
at Module.require (module.js:366:17)

By the way when installing I was having some warnings:

pi@raspberrypi ~/node-flower-bridge $ ./install.sh
npm WARN unmet dependency /home/pi/node-flower-bridge/node_modules/nedb requires async@‘0.2.10’ but will load
npm WARN unmet dependency /home/pi/node-flower-bridge/node_modules/async,
npm WARN unmet dependency which is version 1.5.2

(my version of nodejs is v4.2.2)

Hi @B88

Don’t worry about WARN .

Try $ npm install d and restart

Bruno

Thanks, yes I do an “npm install d” and then others dependences:
"npm install es5-ext memoizee ansi-regex timers-ext s6-iterator noble underscore binary-search-tree mkdirp extend tough-cookie json-stringify-safe bl hawk aws-sign2 http-signature mime-types stringstream caseless forever-agent form-data is-typedarray qs hat-validator node-uuid oauth-sign combined-stream isstream tunnel-agent cron-parser"
and finally I got this error:

– Flower Bridge –

/home/pi/node-flower-bridge/node_modules/flower-power-api/node_modules/node-schedule/node_modules/long-timeout/index.js:25
});
^

SyntaxError: Unexpected token }
at exports.runInThisContext (vm.js:53:16)
at Module._compile (module.js:414:25)
at Object.Module._extensions…js (module.js:442:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:311:12)
at Module.require (module.js:366:17)
at require (module.js:385:17)
at Object. (/home/pi/node-flower-bridge/node_modules/flower-power-api/node_modules/node-schedule/lib/schedule.js:13:8)
at Module._compile (module.js:435:26)
at Object.Module._extensions…js (module.js:442:10)

Finally I try with raspberry 2 and it was fine.
Just two remarks about the readme (https://github.com/Parrot-Developers/node-flower-bridge/blob/master/README.md):

1 Like