Unable to run rviz

I am trying to get rviz to work.
I set up the the slamdunk like the docs suggest. But when i want to start rviz by

rviz -d $(rospack find slamdunk_visualization)/rviz/slamdunk.rviz

it gives the following error:

Segmentation fault (core dumped)

I am trying this on the slamdunk itself.
Has anyone encountered that before?

Hi Pascal456,

I had the exact same problem. I tried to connect the SLAM dunk to a computer but it didn’t solve the problem. I think the error might come from the ip adress of the slam dunk because when using the computer, after the following command:


rviz is still unable to locate the master. And I couldn’t access the internet either, even when connected by Ethernet cable, that’s why an IP issue would be my guess.

I have unfortunately no solution, two days later my SLAM dunk gave me a “starting heat management [fail]” at boot and has been at the post-sale customer service since then…

In my case rviz isnt even starting. I think this is due to the fact, that I am trying to get it to work on the SLAMdunk itself. There are others that also report issues with rviz and the Nvidia Jetson TK1 that is build into the parrot machine:

The Thread owner of the link above is at least able to start rviz. In my case it immediately responds with Segmentation fault. I have reset the SLAMdunk several times and tried some different cofigurations but it will not work for me.

Is it really possible that there is no one else with the exact same problem?

  • Can it be hardware related?
  • Or is it a software issue?

@unix007 would you be so kind and tell me more about the results when you get your slamdunk back from the support?

When I tried on the SLAMdunk itself I had the exact same problem as you and couldn’t solve it, that’s why I decided to connect it to a computer. I know this doesn’t help much but at least you know you’re not the only one with this Segmentation fault (core dumped) error.

Of course no problem I’ll tell you if I have any update. For now the Parrot’s hotline is telling me that the SLAMdunk is not produced anymore so I don’t know even if I’ll ever get a new one … I hope they will keep troubleshooting on this forum even if the production has stopped.

Many thanks!

For now I will try to get it to work with a remote connection on a computer. Maybe this will work for me. But the conditions regarding this are quite tricky. Because of proxy and Windows only. We are not allowed to install Ubuntu on our machines and as far as i know it has to be a Ubuntu 14.04 computer? Virtual Machines do work, but are not allowed to get connection to the internet through the proxy…

They stopped production? I hope that this means that they’re preparing for a new version… Otherwise any further efforts will be useless?

I found a way that seems to work in my case.
The ROS wiki suggests to unset the following environment variable, otherwise it will segfault:


Add this to ~/.bashrc when working on the SLAMdunk directly.

See this for more information:

Just to let you know, Parrot’s customer service just told me that they are out of stock for the SLAMdunk, so I will get a refund…

Glad you found a solution to the segfault though.