Updating the S.L.A.M. Dunk

I am trying to update the S.L.A.M. dunk using the USB mode as outlined here
https://community.parrot.com/t5/Parrot-S-L-A-M-dunk-Knowledge/Updating-Parrot-S-L-A-M-dunk/ta-p/157918

It does not seem to be able to get into update mode. Are there any scripts I would have to enable? How do I know that the update is taking place?

Hello akkasuddin,

They are no scripts to enable update. If the LEDs are flashing only few second after you released the button, the update is not taking place. Try again. If LEDs are flashing after few minutes, the update is taking place.

To investigate, let’s try if your “enter button” is working correctly, connect to the Parrot S.L.A.M.dunk and type:
watch -n 0.1 cat /sys/devices/platform/user-gpio/button_enter/value

When the button is released, it should display 0, when the button is pressed it should display 1.

Can you also share the result of
gprop

and

sudo stop slamdunk_ros_node
sudo diagnostic

My “enter button” seems to be working as expected
I have been trying to update for the past one week now. It never goes into update. These are the steps I followed:

  1. keep enter button pressed
  2. connect power
  3. count to 5
  4. release enter button
    Please let me know where I am going wrong.

slamdunk@slamdunk-000431:~$ gprop
[persist.ulogcat.persist]: [1]
[ro.build.alchemy.product]: [kalamos]
[ro.build.alchemy.variant]: [ad]
[ro.build.date.utc]: [1484311020]
[ro.build.date]: [Fri Jan 13 13:37:00 CET 2017]
[ro.build.hostname]: [0f8f214ec541]
[ro.factory.serial]: [PS741000AA6K000431]
[ro.hardware]: [kalamos]
[ro.model]: [kalamos]
[ro.parrot.build.group]: [drones]
[ro.parrot.build.initial.uid]: [1.0.0-rc5]
[ro.parrot.build.product]: [kalamos]
[ro.parrot.build.project]: [kalamos]
[ro.parrot.build.region]: []
[ro.parrot.build.uid]: [kalamos-ad-1.0.1]
[ro.parrot.build.variant]: [ad]
[ro.parrot.build.version]: [1.0.1]
[ro.revision]: [6]

slamdunk@slamdunk-000431:~$ sudo stop slamdunk_ros_node
[sudo] password for slamdunk:
slamdunk_ros_node stop/waiting
slamdunk@slamdunk-000431:~$ sudo diagnostic
01-linux-version ok [system] Linux version
02-memory ok [system] Memory close to 2GB
03-linux-thermal ok [system] Linux thermal zones availability
04-cpu-governor ok [system] CPU governor
05-linux-sanity ko [system] Linux sanity
20-magnetometer ok [sensors/i2c] Dev ID of AK8963C magn on /dev/i2c-0 (Result: 0x0f)
21-barometer ok [sensors/i2c] Ping MS5607 barometer on /dev/i2c-0
22-codec ok [sensors/i2c] Ping ADAU1772 codec on /dev/i2c-0
25-ultrasound ok [ultrasound] Ultrasound Result: OK Distances: "1.541 1.541 1.541 "
30-camera ok [camera] Cameras acquisition
31-camera-freq ok [camera] Frequency Result: 33.250 ms (33.33 ms) diff=0.24%
32-camera-conn ok [camera] Camera connection: Left is OK and Right OK
40-imu ok [imu] IMU Result: 15911 lines (16000) diff=0.56 %

1 Like

Also, for the update, should I just copy the update_recovery.tar.gz to a flash drive as that is what I did

Hello Akkasuddin,

What’s the LED behaviour of your SLAMdunk during update ?

  • if LED blinks yellow int the 30 firsts seconds, it means it’s not updating (its booting noramally). Might be an issue with USB dongle.
  • Otherwise update lasts 3-4 minutes, and after this it reboots (so yellow blink).

Cheers,

Gaspard

I was finally able to update the firmware. For some reason there was an empty folder created in the /media directory. This is why the update was not taking place. It worked when I deleted this folder. Thanks for all the help!

Great, I’m glad your problem is solved. I marked your last post as a solution.

@akkasuddin I am facing the same problem.
I copied the recovery file as is inside the USB and held the multifunction button , plugged power, held button for ~3 sec . Nothing happens. Just the side LEDs blink directly.

where is this /media folder. I cannot login to the slamdunk as it does not pass boot.

thanks

Never mind. I used a new USB drive to recover the system and it worked as per the manual instructions.