Use Python2 instead of Python


Hi there !
I tried to build the SDK on one of my computers, successfully.
I tried on another, and it failed because #!/usr/bin/env python points on Python3.

Please, please please write

    #!/usr/bin/env python2

instead of

    #!/usr/bin/env python

on top of all the SDK build scripts !

Thanks :slight_smile:


PS : Right now I have to create a virtualenv… So install python-virtualenv. Not great !



The build scripts are designed to work on both python 2 & 3 … so it means that there is a problem!

I’ll try to fix this.



Hi again,

I pushed some changes on the ARSDKBuildUtils repo which should fix the build on python 3. Let me know if it works on your side :wink:



OK for ./ ! That works fine now :smiley:

But there are some other errors :

print 'ARG ' + arg
SyntaxError: Missing parentheses in call to 'print'

A ctrl-maj-F gives me

  • ARSDKBuildUtils/ConfigureWrapper/openssl/customBuild
  • mavlink/generator/lib/minixsv/
  • mavlink/pymavlink/test/


Ok, the issue was on subcalls to python (which on my computer are resolved to python2.7 … I’ll check this again :wink:


Yes, and it seems it’s only about brackets :smiley: