Bebop 2 Software update taking too long


#1

I managed to run Free Flight Pro app to control Bebop 2 on Sphinx. However, I still can’t obtain the live feed from the drone. I am also trying to update the Bebop 2 software after connecting to the drone in Sphinx but the process is taking too long. Any tips on both the problem??


#2

Have you tried running sphinx with th -V option? It is mandatory to get live streaming. If you have a low-end GPU, you may also want to try running sphinx with the drone option low_gpu=true. Example:

sphinx -V /opt/parrot-sphinx/usr/share/sphinx/drones/bebop2.drone::low_gpu=true


#3

As for your second problem concerning the firmware update: it won’t work. The update that comes with Free Flight Pro is meant for the embedded firmware of a real drone. After the simulated drone has downloaded the update file, it might try to reboot fruitlessly. Even IF it’d manage to reboot, the embedded firmware won’t run on x64 :wink:


#5

Yup I did, but after running that command I cannot even connect to the drone and it keeps returning the message “[Network.cc:265] Failed to write on socket 73”


#6

Thanks for the explanation!


#7

That’s weird. Can you try the following commands?

fdc drop_all instances
fdc drop_all firmwares
rm /dev/shm/shd_*

Stop firmwared:
sudo systemctl stop firmwared.service

Delete download firmwares:
sudo rm /usr/share/firmwared/firmwares/*

Restart firmwared:
sudo systemctl start firmwared.service

Relaunch sphinx:
sphinx -V /opt/parrot-sphinx/usr/share/sphinx/drones/bebop2.drone::low_gpu=true


#8

That did not work as well, the same error messages is returned


#9

After launching sphinx, can you give us the output of this command:

fdc show instances $(fdc list instances | sed 's@\[\w*\]@@g')

I am wondering whether the path to your instance (its base_workspace property) could be too long.


#10

Here you go

name: risible_lyndi
sha1: b150fdef75a5a03e4fb6d8527f6d5fb6d6bec6d9
base_workspace: /var/cache/firmwared/mount_points//instances/b150fdef75a5a03e4fb6d8527f6d5fb6d6bec6d9
id: 0
pid: 6464
state: started
firmware_path: /usr/share/firmwared/firmwares//ardrone3-milos_pc.ext2.ac06e4ff-41ff-760c-2582-1562a1f914bd.firmware
root: /var/cache/firmwared/mount_points//instances/b150fdef75a5a03e4fb6d8527f6d5fb6d6bec6d9/union
fs_size: unlimited
inner_pts: /dev/pts/21
outer_pts: /dev/pts/20
time: Wed Oct 4 15:57:59 2017
interface: eth1
stolen_interface: wlan0:eth0:192.168.42.1/24
stolen_btusb_syspath:
cmdline: LD_PRELOAD=libc.so.6:libpthread.so.0 /sbin/boxinit ro.boot.console=/pts/21 ro.hardware=milosboard ro.debuggable=0 ro.debug_ipaddr=10.202.0.1 ro.simulator.kernel.version=4.10.0-35-generic ro.simulator.kernel.build=#39~16.04.1-Ubuntu_SMP_Wed_Sep_13_09:02:42_UTC_2017 ro.simulator.host.arch=x86_64 ro.simulator.host.ip0=10.1.39.135 ro.simulator.host.mac0=f4:4d:30:6d:9e:72 ro.simulator.host.ip1=172.16.0.239 ro.simulator.host.mac1=f8:63:3f:32:33:ae ro.simulator.gpu.hardware=Intel_Corporation ro.simulator.gpu.driver=driver=i915_latency=0 ro.simulator.host.name=yishern-desktop ro.flir=0
debug_ipaddr: 10.202.0.1
owner: yishern-desktop6221


#11

We were able to reproduce your issue and the problem is that your GPU cannot be used to simulate the front camera because sphinx requires a high-end GPU to perform multiple renderings and reconstruct fisheye images. I would suggest launching sphinx with the -V option (to still activate the vertical camera) and disabling the front camera like so:

sphinx -V /opt/parrot-sphinx/usr/share/sphinx/drones/bebop2.drone::with_front_cam=false


#12

I tried disabling the front_cam and enabling the vertical camera and its still not working, I guess the GPU capability just isn’t enough then :slight_smile:

May I ask if I can still obtain the video stream data (I suppose h264) from the camera of the simulated drones in Sphinx?


#13

No, you can’t get the video stream data if your GPU can’t perform the rendering in the first place.