4G not connecting

Since this week, OpenFlight is unable to connect to the drone using 4G. I did everything, factory reset, update latest versions etc but still nothing. “Waiting for authentication token”. Drone is “connected to parrot servers”

FreeFlight7 still connects fine. What is going on here?

1 Like

I have the same issue ,parrot support made contact after a help request last Thursday waiting for a update after connection logs reviewed

Unbelievable, there has been no communication about this at all. Good to know that I’m not alone. Could you share more details about your case? Also, have they told you how long it will take?

Hi I went through the same reset procedures as yourself to resolve waiting for server on the left side or 4g connection refused by provider messages on the right side on the cellular access page these messages came at different times during troubleshooting I used the help and connection logs were sent , initially dismissed as a 4g provider issue I installed another sim sent a second request when results were the same , they have since responded on Thursday saying it seems the drone is not able to connect to the 4g network can you send another support request which I did and am awaiting an update I’m going to email again today

1 Like

I had an issue connecting to 4G in the very beginning, it was due to my phone being connected through a VPN. Check that you aren’t, if you are, disconnect and try again.


After investigating the issue we were not able to reproduce it with OpenFlight connecting to a drone through 4G.

Do you still have the issue on your side?


The issue seems to have been resolved a couple of days ago.

I am pretty confident that something was wrong on the backend. My observations were the following

  • 4G connected through FreeFlight7 (this was never broken)
  • Unmodified OpenFlight (v7.5.0) did not connect with 4G. I was also in wifi range and wifi was connected.
  • Did complete reset of the drone, skycontroller. Updated everything to latest versions (7.5.0/7.5.1) and re-installed both freeflight and openflight on the Ipad

The first time I noticed it wasn’t working was when I posted this question (March 7th). The first time I got connection again was March 10 (without any changes on my side).

Thank you for the additional info.

At this point we are not able to trace the incident neither on the Parrot Cloud servers nor on the SIP backend used for 4G…

@Akaaba Thanks for checking. Unfortunately we’re running into a connectivity problem again. The behavior is interesting:

Context: The drone is in a box far outside wifi range. The last time we had it in wifi range was 6 days ago.

  • We turned on the drone
  • We started the remote controller and opened OpenFlight. It would hang at “Connected to Parrot servers”
  • We closed OpenFlight and started FreeFlight7. It would briefly (less than 20 seconds) show the full connection and display the name of our mobile provider. Then it disconnected.
  • After that, both OpenFlight and FreeFlight do not connect anymore. We tried rebooting everything but no luck.

I am able to connect into the drone using our dronebox and ADB. I can verify that the drone has internet connection by issuing “wget mapture.ai” for example. Is there any ADB command we can try to further debug the connection. Is it possible to see more information in the Parrot Cloud servers or SIP backend?

Regards, Bart

Interesting observations: Apparently the drone started synchronising with FreeFlight7, which disabled the 4G modem. Then all 4G connection was lost. I now managed to connect through our dronebox using Olympe and re-enabled the 4G modem. The drone now connects again through FreeFlight7.

However, the connection through OpenFlight is still not working.

This topic was automatically closed after 30 days. New replies are no longer allowed.