Bluetooth deactivated whenever I tried to connect to mambo


#1

Hi. I’m trying to use parrot-sphinx simulator with mambo drone.
My OS is Ubuntu 18.04, so I unnaturally installed parrot-sphinx via .deb file due to its ulogger-dkms dependency issue. (I hope this issue will be fixed as soon as possible…)
I also set CSR bluetooth dongle, 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode), which is what I’ve got from the command lsusb | grep bluetooth -i.
Then I wrote my mambo.drone config file like below:

<?xml version="1.0" encoding="UTF-8"?>
<drone
  name="mambo"
  firmware="http://plf.parrot.com/sphinx/firmwares/delos/v3_pc/latest/images/delos-v3_pc.ext2.zip"
  hardware="delos3board">
  <pose>default</pose>
  <!-- !! to be completed with your actual Bluetooth MAC address !! -->
  <stolen_bdaddr>00:1A:7D:DA:71:13</stolen_bdaddr>
</drone>

I set the stolen_bdaddr part as manual instructed.
Then I run sphinx with sphinx ~/mambo.drone command, with bluetooth-connected mobile phone, Samsung Galaxy S8, FreeFlight Mini.
However, as soon as sphinx starts up, the bluetooth is turned off and I got nothing from drone list.
What am I missing?
Does anyone have similar phenomenon?
Please help me out. Thanks.


#2

Oh, and before I start sphinx, I also systemctl start firmwared.service, too. But it doesn’t work anyway.


#3

Mambo firmwares are incompatible with Ubuntu 18.04 Bionic. A new firmware that fixes this issue will soon be published.