Building a world app for sphinx simulator in UE4 : Encountering issues

Hello there! :wave:

I’m currently working on building my own world for the Sphinx simulator using Unreal Engine 4. I’ve followed the entire process as outlined in the Parrot Sphinx documentation.

My level is quite simple, consisting of a floor, a single spawning point, and a Parrot BP_Sky. I’ve disabled the game modes and added the following lines to my config file:

[/Script/EngineSettings.GameMapsSettings]
EditorStartupMap=/Game/Maps/main
GameDefaultMap=/Game/Maps/main
;GlobalDefaultGameMode=/Script/@@@GAMEMODE@@@
;GameInstanceClass=/Script/@@@GAMEINST@@@

[/Script/Engine.RendererSettings]
r.DefaultFeature.AutoExposure.ExtendDefaultLuminanceRange=True

The application builds successfully, and I receive the following exit message:

==================================================================
Your application is available in the following directory:
        "/DATA/PARROT/NEW_UE4_WORLDS/HaniTest1/installed/"
It is compatible with Parrot-Sphinx 2.15.1
==================================================================

However, when I attempt to launch UnrealApp.sh, I encounter an error:

Failed to find symbol file, expected location:
"/DATA/PARROT/NEW_UE4_WORLDS/FredTest1/installed/LinuxNoEditor/Parrot-Sphinx-App/Binaries/Linux/UnrealApp.sym"
Fatal error: [File:/docker_mounts/pipeline-unreal-editor/checkout/Engine/Source/Runtime/Engine/Private/Materials/MaterialShared.cpp] [Line: 1973] 
Failed to find shader map for default material WorldGridMaterial(/Engine/EngineMaterials/WorldGridMaterial.WorldGridMaterial)! Please make sure cooking was successful (Contains inline shaders, has GTSM)

Indeed, the UnrealApp.sym and UnrealApp.debug files appear to be missing. Is there something I might be doing wrong? I appreciate any assistance you can provide. Thank you for your time!

Hello,

Did you make sure to use the same engine version as the SDK: Parrot-customized UE Editor - 2.15.1 ?

I think that the GameMapsSettings section should contain the following lines:
EditorStartupMap=/Game/Maps/main.main
GameDefaultMap=/Game/Maps/main.main

First of all, thank you for your reply.
Yes, I’m currently using version 2.15. I think the problem is with parrot-ue-build-app because even if I get a success message, at the end I’m missing 2 files: UnrealApp.sym and UnrealApp.debug.

I am not sure what seems to be the issue here. UnrealApp.sym and UnrealApp.debug files are not supposed to be generated, so you can ignore this message. The real issue is the missing WorldGridMaterial. Does it work if you remove the BP_ParrotSky?

If main is the name of your map in Content/Maps/, your DefaultEngine.ini should look like this:

[URL]
[/Script/Engine.RendererSettings]
r.DefaultFeature.AutoExposure.ExtendDefaultLuminanceRange=True

[/Script/HardwareTargeting.HardwareTargetingSettings]
TargetedHardwareClass=Desktop
AppliedTargetedHardwareClass=Desktop
DefaultGraphicsPerformance=Maximum
AppliedDefaultGraphicsPerformance=Maximum

[/Script/EngineSettings.GameMapsSettings]
EditorStartupMap=/Game/Maps/main.main
GameDefaultMap=/Game/Maps/main.main
;GlobalDefaultGameMode=/Script/@@@GAMEMODE@@@
;GameInstanceClass=/Script/@@@GAMEINST@@@

And your DefaultEngine.ini should contain this line:

[/Script/UnrealEd.ProjectPackagingSettings]
+MapsToCook=(FilePath="/Game/Maps/main")

Hello,

As mentioned in the documentation Adapt an UE project to Parrot Sphinx - 2.15.1, is the “Allow static lighting” option set to “False” in your project settings?

If not, try to set it using the editor under “Project Settings”, or by simply adding these lines in your Config/DefaultEngine.ini

[/Script/Engine.RendererSettings]
r.AllowStaticLighting=False