Connecting to a physical drone using olympe

i’m using Parrot AR drone 2.0
Following the document (Overview - 7.7), i’m trying to control this drone. However, if i run this code,

import olympe

drone = olympe.Drone(“”)

i get this.

(olympe-python3) james@james-870Z5G-880Z5F:~/code/parrot-groundsdk$ python
27/06/2019 13:53:52.408513 _create_pomp_loop Creating pomp loop
27/06/2019 13:53:52.408922 _create_manager New manager has been created!
27/06/2019 13:53:52.409064 _create_manager Manager device callbacks has been added to the manager
27/06/2019 13:53:52.409284 _create_net_backend New net backend has been created
27/06/2019 13:53:52.409419 _create_net_backend Set backend socket callback OK
27/06/2019 13:53:52.409550 create_timer Creating pomp timer
27/06/2019 13:53:52.409698 create_timer Creating pomp timer
27/06/2019 13:53:52.429140 _start_net_discovery Net discovery object has been created
I arsdkctrl: discovery ‘net’: start
27/06/2019 13:53:52.429488 _backend_socket_cb backend_pointer <olympe_deps.LP_struct_arsdkctrl_backend_net object at 0x7f7fc1b8bf28> socket_fd 10 socket_kind 0 userdate_pointer None
27/06/2019 13:53:52.429717 _start_net_discovery Net discovery has been started
I arsdkctrl: discovery ‘net’: stop
27/06/2019 13:53:57.490303 connection Unable to connect to the device. IP : b’’
27/06/2019 13:53:57.490604 _stop_discovery Discovery has been stopped
27/06/2019 13:53:57.490859 _stop_discovery Discovery object has been destroyed
27/06/2019 13:53:57.491145 _stop_discovery No discovery instance to be stopped
27/06/2019 13:53:57.492408 _destroy_net_backend Net backend has been destroyed
27/06/2019 13:53:57.492646 _destroy_manager Manager has been destroyed
27/06/2019 13:53:57.492909 destroy_timer Pomp loop timer has been destroyed
27/06/2019 13:53:57.493140 destroy_timer Pomp loop timer has been destroyed
27/06/2019 13:53:57.493346 _destroy_pomp_loop Pomp loop has been destroyed

i saw that some one in this forum had similar problem before. But that person had ANAFI and he had to add the type of the drone after the IP address. I don’t know what to write for my drone’s type tho.
Can anyone help me?
If there is another way to control this drone, i’ll be glad to know that too!
Thank you!

btw, i tried other ip address like "" or "" which were what i found on drone’s wifi setting. Same result tho.

This drone is not supported in Olympe.

Hello, do you know where I can find the list of drones that Olympe can support?

Bebop, Disco, Bebop 2 and Anafi
We recommend using Anafi, as we can not garanti the future support for the other platforms.

@Jerome, olympe does not support minidrones (I already took the liberty to edit your answer).

1 Like

Thanks a lot