Connecting to anafi with laptop in python linux

hi, i have a problem with connecting my laptop to anafi. ive installed olympe sdk for controlling anafi from laptop in python in ubuntu but you should connect to drone first to send commands. i can just connect with my laptops wifi and i cant conect from terminal to send commands i have a problem in drone=olympe.Drone(“ip address”) i put ip address but it doesnt work.

Hi,
please follow each step from https://developer.parrot.com/docs/olympe/installation.html#installation and post messages with a clear status and the faulty step.
Thanks

hi jerome,
i’ve installed olympe for anafi even i’ve installed 1.0.1 but i cant connect too actual drone. what should i write in ip address bar in this code? drone = olympe.Drone(“10.202.0.1”). cause when i write drone.connection() i get this.drone.connection()
03/07/2019 07:37:39.022845 _start_net_discovery Net discovery object has been created
I arsdkctrl: discovery ‘net’: start
03/07/2019 07:37:39.023846 _backend_socket_cb backend_pointer <olympe_deps.LP_struct_arsdkctrl_backend_net object at 0x7f25e8c19510> socket_fd 10 socket_kind 0 userdate_pointer None
03/07/2019 07:37:39.024578 _start_net_discovery Net discovery has been started
03/07/2019 07:37:41.025717 _backend_socket_cb backend_pointer <olympe_deps.LP_struct_arsdkctrl_backend_net object at 0x7f25e8bfd950> socket_fd 10 socket_kind 0 userdate_pointer None
03/07/2019 07:37:43.027004 _backend_socket_cb backend_pointer <olympe_deps.LP_struct_arsdkctrl_backend_net object at 0x7f25e8bfd950> socket_fd 10 socket_kind 0 userdate_pointer None
I arsdkctrl: discovery ‘net’: stop
03/07/2019 07:37:44.091229 connection Unable to connect to the device. IP : b’192.168.42.73’
ReturnTuple(OK=False, message="Unable to connect to the device. IP : b’192.168.42.73’ ", value=None, error_code=107)

03/07/2019 07:37:44.091954 _stop_discovery Discovery has been stopped
03/07/2019 07:37:44.092639 _stop_discovery Discovery object has been destroyed
and im using anafi drone my laptop is connected to the drone but i cant connect to it in terminal.

are you sure this is the correct log? The IP address seems wrong…

What is the output of the following script?

import olympe
drone = olympe.Drone("10.202.0.1")
drone.connection()

hi
when i run
import olympe
drone = olympe.Drone(“10.202.0.1”)
drone.cennection()
i get the same error i dont know why

Hi,

This should be drone.connection().

If that doesn’t solve your problem, I will need more information…

Which drone are you trying to connect to ? A simulated drone or a physical one ?

  • For a simulated drone (with running with Parrot-Sphinx), the IP address of the drone is 10.202.0.1 by default.
    Have you checked the Sphinx system requirements ?
    Have you installed sphinx yet ? What is the console output of Sphinx ?

  • For a physical drone, you should first connect to the drone wifi SSID and then connect to the drone at 192.168.42.1.

thank you for your helps ive connected to the drone and i can send commands to anafi.
but i have another problem now when i use move by command when i use these values (5, 0, 0, 0,)
for moving the drone it doesnt work it just work with (10, 0, 0, 0) i dont know why.