Error building olympe-linux ("task 'alchemy' failed")

I’ve looked through many other parts of the forum at people having errors building SDK, but the topics are either unsolved or I tried the solutions and am still getting the same error. When I run the command ‘./ -p olympe-linux -A all final -j’ as it says in the Olympe installation documentation, I end up with error code:
[E] Task ‘alchemy’ failed (Command failed (returncode=2))”

I’ve installed what I believe to be all the necessary tools for building SDK, which are:

  • git
  • build-essential
  • autoconf
  • libtool
  • libavahi-client-dev
  • libavcodec-dev
  • libavformat-dev
  • libswscale-dev
  • libncurses5-dev
  • mplayer

Any ideas or suggestions to how to get this to build would be greatly appreciated. I’m relatively new to using Ubuntu (18.04), so I’ll do my best to answer questions about what packages I do and don’t have.

I know it says "No module named ‘clang’ " but I can guarantee that I do in fact have clang installed.

1 Like

I had the same issue when trying to implement this fix for the ffmpeg issues in Olympe.

$ cd ~/code/parrot-groundsdk
$ sed -ie ‘s/# (.)_AVC_DECODING./\1_AVC_DECODING=y/’ ./products/olympe/linux/config/ffmpeg-libav.config
$ ./ -p olympe-linux -A all final -j

Any idea @ndessart ?

Quick update on my particular case: we went ahead and did a complete reinstall of Ubuntu 18.04, and the installation of the Olympe packages went off without a hitch this time. I had installed Anaconda on the system beforehand for other tasks, and in doing so I had also installed Python 3.7.3. Now, using the Python 2.7.15 native to Ubuntu 18.04, it worked fine.

1 Like


I have little to no experience with Anaconda and the Olympe dependency installation script has not been tested in an Anaconda environment. This script tries really hard to use /usr/bin/python3 and the system pip to “pip install clang”. I guess it won’t install the package in the Anaconda environment…

I’ll update the documentation to make it clear that this script is not compatible with Anaconda.



1 Like

At the very least, not compatible if Anaconda was installed first. I installed Anaconda for 2.7 just to use as a script editor after I successfully installed Olympe, and the olympe shell still works just fine. If something breaks, I’ll uninstall Anaconda and keep you updated.