Failed to start sphinx 1st usage


#21

You should always use FreeFlight Mini for minidrones and FreeFlight Pro for Bebop drones. The Bebop Thermal requires a SkyController 2 exclusively. It won’t work with a Flypad. You should be able to control a Bebop 2 with FreeFlight Pro installed on your smartphone.


#22

Ok didn’t know about thermal should only with sc2. About app on smartphone I installed all of them, ffmini ffpro & ffthermal. Ffpro, with flypad connected and connected wifi to the emulated bebop2 and sphinx running It, tell that there is no drone connected. All I can obtain is connecting … https://ibb.co/hOPJPn


#23

Have you tried to establish a connection with a Bebop 2 with no other modification than with_front_cam=false?
Does your Linux distribution run in a container or in a virtual environment?


#24

No virtual environment. Real fisical installation
V=1 sphinx --datalog /opt/parrot-sphinx/usr/share/sphinx/worlds/outdoor_1.world /opt/parrot-sphinx/usr/share/sphinx/drones/bebop2.drone::with_front_cam=false::stolen_interface=wlx8416f9191aee:eth0:192.168.42.1/24

Is there a way to avoid every time if I start a new drone that sphinx download itself because I use a mobile internet connection, and I already downloaded all possible fws and stored in Downloads directory?


#25

By default, sphinx downloads the latest firmware versions and put them in /usr/share/firmwared/firmwares/. If we don’t release a new firmware version, it shouldn’t perform any download and reuse the firmware it already downloaded. If you really want to be sure that sphinx doesn’t download an already downloaded firmware, just launch sphinx with the firmware option set to the path to your firmware. For example:
sphinx /opt/parrot-sphinx/usr/share/sphinx/drones/bebop2.drone::with_front_cam=false::stolen_interface=wlx8416f9191aee:eth0:192.168.42.1/24::firmware=/usr/share/firmwared/firmwares/bebop2.firmware

If the name of your wifi interface changes after exiting the simulation, it is recommended to follow this procedure to set it to wlan0: http://developer.parrot.com/docs/sphinx/troubleshooting.html#my-wifi-interface-got-its-name-changed-after-exiting-the-simulation
Then, you won’t have to specify a stolen_interface in your command line.


#26

Rendering on the smartphone screen has viewable lags, my gpu does not goes up to 35% utilisation (gtx1050ti), cpu 75% (poor amd a8 5500). After a virtual crash down and resetting a world, the 1st usage camera usage is lost while the drone is still connected. Must exit the fly & film section even if the drone is back on line and taken off, hovering & waiting (commands that were send without front camera working)
Parrot should definitely develop ffpro and ffthermal MOVABLE to Sdcard. Is the real a way to connect a Swing with a 0a5c:200a BT device? cat /sys/kernel/debug/usb/devices | grep "CSR" -B2 gives no output hcitool scan does the same Scanning ... I know It seems not to have CSR chipset but could be used flypad and emu swing or my cousin’s real swing?


#27

The front fish-eye camera is simulated by performing six renderings simultaneously merged into a single large texture with the help of shaders (see http://gazebosim.org/tutorials?tut=wide_angle_camera for a reference). This operation is already quite costly, but the real bottleneck is that, even though we use a shared memory to send frames to the simulated firmware, we still have to move the data from the GPU to the CPU and back several times. We are aware that not all users have the required processing power to perform all these operations and that’s why we added the “low_gpu” and “with_front_cam” options. We also have plans to improve the rendering procedure in the future.
Anyhow, you can always check the real-time factor in sphinx-client (at the bottom of the screen). With your GPU, my guess is that it shouldn’t be below 50%.

I failed to reproduce your camera usage issue (requiring to exit the fly &film section), but we will have a look into it.

I am sorry but if your bluetooth device is not CSR-based, you won’t be able to connect to a simulated Swing.


#28

Hello! Help me, please. I did all those actions, but i don`t see the drone in Gazebo program, what i did wrong?


#29

Hello,

firmwared may have failed to download the ext2.zip file. I would recommend dropping all firmwares with this command:

fdc drop_all firmwares

Then make sure that /usr/share/firmwared/firmwares/ is empty and restart sphinx.


#30

I did it, but now
$ sudo systemctl start firmwared.service
sphinx /opt/parrot-sphinx/usr/share/sphinx/drones/bebop2.drone::with_front_cam=false
Sphinx simulator version 0.29.1

Connection with firmwared timed out

Tell me, please, should i run command “sudo firmwared” after “sudo systemctl start firmwared.service”


#31

You must not run both commands.
It is recommended to start firmwared as a service once and for all with:

sudo systemctl start firmwared.service

You can check that firmwared is running by pinging it with this command:

fdc ping

You can also verify that firmwared is running with ps:

ps ax|grep firmwared

#32

I guess, my problem due to http-proxy, which don`t allow download ext2.zip


#33

If you can access ext2.zip files from another machine, you can copy them on the machine where sphinx is installed, then launch sphinx with the ::firmware option like so:

sphinx 
/opt/parrot-sphinx/usr/share/sphinx/drones/bebop2.drone::with_front_cam=false::firmware=/path/to/ardrone3-milos_pc.ext2.zip

#34

thank you very much!!! It works!!!