Failed to start sphinx 1st usage

First start of sphinx hang on, It waits forum 4ever. I use sphinx --datalog path to outworld1 path to bebop2 with robbendevice inside. But It did not work. Copied also the zipped & unzipped fw files in the drone folder. No success. xubuntu 16.04 updated. Kernel 4.4.x


Have you tried running sphinx without camera?
sphinx --datalog /opt/parrot-sphinx/usr/share/sphinx/drones/bebop2.drone::with_front_cam=false
Sphinx requires a high-end GPU to perform multiple renderings and reconstruct fisheye images.

My GPU is not a High end, evga 1050ti but Nvidia log does not show any further usage
Your suggestion did not work

Other suggestions? Any useful idea would be appreciated

I suggest you follow that procedure:

Clean firmware artifacts:
fdc drop_all instances
fdc drop_all firmwares
rm /dev/shm/shd_*

Stop firmwared:
sudo systemctl stop firmwared.service

Delete download firmwares:
sudo rm /usr/share/firmwared/firmwares/*

Reinstall parrot-sphinx:
sudo apt-get remove --purge parrot-sphinx
sudo apt-get install parrot-sphinx

Restart your machine.

Restart firmwared:
sudo systemctl start firmwared.service

Relaunch sphinx:
sphinx /opt/parrot-sphinx/usr/share/sphinx/drones/bebop2.drone::with_front_cam=false

And, if that does not work, you can show us the logs you get while launching sphinx and the logs you get in your ~/.gazebo/ogre.log file.

1 Like

Did not work one more time here the log. I have divided each command with **** asterisks, and highlighted problem with # seems that should be a problem with a directory (grep: 341060B0508VFD-510_MRB01-1(SD card software): È una directory - It is a directory).

In your command line, you should first try without stolen_interface and see if that works.
And if you use stolen_interface, it should contain the entire string, not just the name of your wifi interface:
sphinx --datalog /opt/parrot-sphinx/usr/share/sphinx/drones/bebop2.drone::with_front_cam=false::stolen_interface=wlx8416f9191aee:eth0:

Already tried without wifi device & stolen device option. Gazebo log are the same, empty both times. No CPU & no GPU usage. Log with your own command line no changes

Can you try again with V=1? Thanks.
V=1 sphinx --datalog /opt/parrot-sphinx/usr/share/sphinx/drones/bebop2.drone::with_front_cam=false

Something changes in the log of sphinx command line, have a look at the bottom, seems complaining about no that world is on. No Cpu & gpu usages, no gazebo log.

It looks like the same log as before.

No these were missing.

[Err] [] File or path does not exist["/tmp/"]
[Err] [] Could not open file[/tmp/]
[Err] [] Error while parsing command line arguments
escalating to SIGKILL on client

All other logs are the same unfortunately.

I mean, as far as I can see, you did not use V=1 in front of sphinx so the logs are essentially the same. Do you have a /tmp folder in your filesystem? If not, you should definitely create it before launching sphinx.

My bad, I omitted V=1 option. Here is the log hp@hp-desktop:~$ V=1 sphinx --datalog /opt/parrot-sphinx/usr/share/sphinx/drones -
But no gpu & cpu usage.

Found a ogreg.log here nc_interop GL_NV_shader_thread_group GL_NV_shader_thread_shuffle GL_KHR_blend_eq - sorry

You encountered a known issue that will be fixed in the next version of sphinx.
You should remove files that start with a digit in the directory where you launch sphinx or you can fix it yourself by editing the file /opt/parrot-sphinx/usr/bin/sphinx
To change this line:
GZSID=$(ps -o sid ${GZPID} |grep -o [0-9]*)
into this:
GZSID=$(ps -o sid "${GZPID}" |grep -o '[0-9]*')
Sorry about that.

I moved the file 133hd.mp4 meanwhile without knowing the issue to another folder but no success at all. Seems that the number starting file name extends to directory. Where should I store the zipped and unzipped fw files to avoid mobile data usage? Cause I putted them both in drones directory & my home directory unsuccessfully

Once downloaded, files are automatically uncompressed and archived in the /usr/share/firmwared/firmwares/ folder. If you want, you can change this path as explained here:

Got another problem

You forgot stolen_interface in your command line:
V=1 sphinx --datalog /opt/parrot-sphinx/usr/share/sphinx/drones/bebop2.drone::with_front_cam=false::stolen_interface=wlx8416f9191aee:eth0:

Is there a way to use a simulated device delos device and usb tethered android smartphone on which is running wifi ffpro. Because seems that ffpro (which I install via apk search to connect to a wifi INTERNET connection and a flypad from my real Parrot swing. Also tried sphinx with hd battery, flir vertical, flir true but parrot thermal connect to the virtual delos AP in the wifi sub menu but does not find any virtual bebop2 thermal