[Firmwared] Cannot re-run Sphinx without restarting the computer


#1

I have been able to install and run Sphinx with bebop2. Currently, I am having a problem that I believe is related to Firmwared package that needs to be run.

Whenever I need to close my simulation or reset the pose of the drone, the simulation closes and the terminal brings the following error:

[Err] [Machine.cc:970] Failed to start bebop2 : net.hook/assign failed.
[Err] [Machine.cc:977] Probable cause for this error: the requested stolen interface (wlp5s0:eth0:192.168.42.1/24) does not exist

In order to be able to run the simulation again, I have to restart my machine. If I do try to run sphinx /opt/…/bebop2.drone again, the same error comes.

I have run the network compatibility and it shows my wireless card is compatible. (If it wasn’t it would not even had run in the first place)

How do I recover from this error without restarting my machine?


#2

Hello,

Have you tried to create a udev rule to set a persistent name for your wifi interface? The procedure is explained here:
https://developer.parrot.com/docs/sphinx/troubleshooting.html#my-wifi-interface-got-its-name-changed-after-exiting-the-simulation