FlightPlans and SPHINX


#1

I’d like to test a flight plan in SPHINX with the Bebop2 model. Does it simulate an FTP server so I can upload a mission? I tried connecting to 10.202.0.1 port 61 but there was no response.


#2

It should work. You can upload files with an FTP client and they will appear in your firmware file system. For instance:
curl -T /path/to/file ftp://10.202.0.1/internal_000/flightplans/


#3

This is what I get when I run that command:

vo@kraken:~$ curl -T test.txt ftp://10.202.0.1:61/internal_000/flightplans/
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0

FTP connections seem to disconnect immediately and no file is uploaded.

However, API code works (I can run the Unix C sample in the API to takeoff and land the aircraft that’s runnign in SPHINX) so it appears that the firmware is running.


#4

Your command line doesn’t work, but these two command lines should succeed:
curl -T test.txt ftp://10.202.0.1:61/
curl -T test.txt ftp://10.202.0.1/internal_000/flightplans/
They both put test.txt in /data/ftp/internal_000/flightplans


#5

Confirmed, this works.