Freeflight asks for update for simulated drone


I am currently simulating a 3.0.17 Mambo drone in Sphinx. When I connect to the FreeFlight App, it asks for an update to the version 3.0.26. This version is not yet available at the Parrot Firmware Image for Sphinx Index.

Is there a way to “cheat” the app to fly an late version simulated drone? Or is there any idea when the latest firmware will be available?

Thank you!

For some reason the firmware update site has offered 3.0.26 for download for quite some time but the link it provides has never worked.

I believe you can find 3.0.25 on the Parrot website.

1 Like

Hi @synman,

Thanks for the tip! I couldn’t find the link for the 3.0.25 zip file of the Mambo firmware image for Sphinx. Even the latest firmware link at the image index doesn’t work. Free Flight app says it is the 3.0.17 firmware.

Could you send me this link for the 3.0.25 version?

Thank you for your attention!

I managed to download the old version (5.3.3) of Freeflight Mini APK. I also changed my mambo.drone file to

<?xml version="1.0" encoding="UTF-8"?>
  <!-- !! to be completed with your actual Bluetooth MAC address !! -->
  <!-- <stolen_bdaddr>00:1A:7D:DA:71:13</stolen_bdaddr> -->

It worked!

PS: I am working with Ubuntu 16.04. Could not make the bluetooth recognition work within Ubuntu 18.

1 Like