Ground SDK Demo build

Thank you very much for this!!!

Just a small problem: Trying to build the demo project (installed with Homebrew - not pods install) I get several:

/Users/vassilisangelakos/groundsdk/packages/groundsdk-ios/demo/…/base.xcconfig:2: could not find included file ‘…/…/…/out/product.xcconfig’ in search paths (in target ‘GroundSdkDemo’)

Just FYI.

Best Regards

1 Like


Does the command-line build works ? (The ./ -p groundsdk-ios -t build -j command).
A first command-line build is required before the Xcode project can work, as it will build some core libraries handled by our own build system.


Thank you Nicolas!

Initially the script could not run saying “error: SDK “iphoneos” cannot be located” I resolved this issue by opening Xcode --> Preferences --> Locations --> Setting Command Line Tools option to the version of installed Xcode (10.2.1). - After this change and running the script I got **** BUILD SUCCEEDED ****

Now trying to build Groundsdk workspace inside Xcode I get:

‘libpomp.h’ file not found – Line 32 of PompLoopUtil.m

Totally I have 4 errors this is the first one.

Many thanks

1 Like

Which target do you use in Xcode? A simulator or a connected device?
For a simulator, you must have built with the command:
./ -p groundsdk-ios_sim -t build -j

Yes!!! :heart_eyes:

Running ./ -p groundsdk-ios_sim -t build -j solved the problem!

Many Thanks!

1 Like

Great :slight_smile:

Thank you!

I had the same problem.
But it was solved with your Xcode setting.