GroundSDK Demo Not Connecting to Drone

Hello,

I ran through the tutorial on the groundsdkdemo, and was successfully able to run groundsdkdemo on my computer and install the app on my Android phone. However, when I connect my phone to the Anafi AI wifi the drone still does not show up as a device to connect to within the Demo app. Not sure the problem and not sure if it has anything to do with the steps listed in Setup Ground SDK AAR - 7.3. I was unable to get the demo to compile after trying to make the changes to listed in the link.

Thanks.

Hello @pattentllc,

Is your phone connected to the drone’s WiFi, or is it your phone connected to a SkyController that is paired to the drone?

If you want to connect directly from your phone to the drone then your phone should be connected to the drone’s WiFi.

If you want to connect to the drone via a SkyController then you should connect your phone to the SkyController, open GroundSdkDemo, select the discovered remote controller, and connect to it. If the drone is already paired with the controller then the drone should appear on the list of GroundSdkDemo. If not then you should pair the controller with the drone.

Georges

My phone is connected to the Anafi Ai’s wifi, but when I look in the demo app the drone does not pop up as an option to connect. I think the controller is already paired with the drone since I can move the drone camera via controller. Right now it seems like neither the controller nor the drone show up in the demo app to connect.

This topic was automatically closed after 30 days. New replies are no longer allowed.