isoCountryCode doesn't work

Hello,

Please, let us know how to change the country in the Wifi Access point settings.
We set the proper variable “AutoSelectWifiCountry” to false and ask for availableCountries. We have successfully received the return list contains all countries and than we tried to change the WiFi country by isoCountryCode but the drone doesn’t accept the changing.
This procedure worked correctly with Anafi’s firmware versions prior to 1.6.4…
Where do we wrong?

Best regards
Auriga Team

Hello,
we are aware of this issue and this should be fixed with the next firmware update.

2 Likes
Great!! Thank you

I may have cross posted… My apologies as this sounds like the same issue I just reported.

I just got new Anafi Thermal from Dronenerds today. Should i wait for the next update before I start. I heard that lhe 1.6.5 and 6 locks me into CE and restricts

I believe this condition has existed since 1.6.4

What is the best work around, if any?

You guys are talking 2 different problems : one is the problem related to the SDK of selecting country.
@jbuy41 is just using FreeFlight with the retail product, there is no impact on this.
This is a developer forum only, thus we are dealing with developer questions.

There is no work-around at this time.

It would seem Parrot has no idea what they are doing with firmware updates if they lock North American users into CE mode which they seemed have done.

Hello Jerome,

We noted that the new firmware updated 1.6.7 don’t solve this issue.
Please when do you plan to issue a new update for that? We are ready to publish our application but we are going to wait for it first…
Thank you
Auriga Team

It certainly is the same issue as auto selection is not working as well… Covered in the post I linked above.

It appears drone’s are getting locked to a default country (possibly tied to a regulatory zone they were manufactured for) post 1.6.4+ update.

There is no SDK issue here. I’ve issued and reviewed the raw commands / responses.

Hi Synman,
you’re right, we figure out it too (drone’s are getting locked to a default country) and the issue is not about SDK but it is no compatible with Anafi’s firmware, so… we are waiting for a new firmware for the drone.

2 Likes

Hello all, we have identified the problem and are working on a fix.
This will require a firmware update, but nothing on the SDK side!

4 Likes