Issues when connecting to a remote running sphinx-server

Hello everyone,

I’m trying to run sphinx-server on a remote GPU server, that works fine but then I’m experimenting issues getting connected to the remote sphinx-server.

On the server, I’m running, my ethernet interface is enp4s0: ;
In order to get a drone accessible from outside the server, I used the port-forwarding option of sphinx-server and therefore ran :

On server : 
DISPLAY=:99 sphinx-server /opt/parrot-sphinx/usr/share/sphinx/worlds/ /opt/parrot-sphinx/usr/share/sphinx/drones/bebop2.drone::stolen_interface=::with_front_cam=true --port-forwarding=

Do not bother too much about the front “DISPLAY=:99”, it is because I use a headless server and a xserver-xorg-video-dummy X server.

By the way, I think the simualtion is running ok , since I can display an image from the front cam :

ssh -X @server
gz topic --view /gazebo/default/bebop2/body/horizontal_camera/image
>> This opens a widget and displays an image

gz stats
>> Factor[0.62] SimTime[91.64] RealTime[146.49] Paused[F]

The issue I get is to connect to the simulation from a remote client. I’m on the same network so I can ping the IP. But then , trying to connect to the gazebo master seems to partly fail

The topic list seems to work

gz topic -l 

But requesting stats seems to fail :

On my client: 
gz stats 
>> does not display anything

requesting an image with gz topic --view does not work either (it does not display any image). And requesting frequency on the topic does not return anything.

I also tried to run sphinx-client --server-uri= ; it opens a gazebo GUI with a black screen.

I finally tried to connect to with the bebop_autonomy ROS driver but it seems to fail to connect.

Do you have any idea on where can be the issue ?

Thanks for your help.

OK, actually , part of the problem was coming from conflicting gazebo versions.

My server is on 16.04 with gazebo 7 ; and my client on 18.04 with gazebo 9 ; So I suppose that explains that “gz” partially works.

Still , I cannot connect to the simulated drone. But I’m testing the connection only indirectly through the bebop_autonomy ROS package. There might be a more direct way to test the connection , I suppose ?