moveBy and moveTo sometimes don't work

I’m trying to control a drone from a python program using olympe, but sometimes moveBy and moveTo stop working.
I’m Japanese and I use google translate to generate this sentence, so I apologize in advance for any possible poor wording.

I used moveBy to verify if it worked, but in my environment whenever moveBy doesn’t work moveTo doesn’t either.
Here are the conditions I’ve experienced when moveBy works and when it doesn’t:
・It works immediately after the drone starts up.
・If you use PCMD and move the drone for a while, it may stop working.
・Once it stops working, it will not work even if you repeat landings and takeoffs or restart the program.
・When you restart the drone, it will work again.

What I want to know is
・Why do moveBy and moveTo stop working?(Is there a way to make the drone work again without rebooting?)
・When it didn’t work, is there a way to programmatically detect that it didn’t work?
・I would like to use moveTo to return the drone to its takeoff point and land it, is there any other way? (I tried NavigateHome, but I felt that it was useless to fly up to the limit altitude to return home, and when it was close to the takeoff point, I could not use it because it just turned to it and did not change its position.)

Here I am attaching the logs when the moveBy succeeds and when it fails. In both cases, moveBy is performed when a key is pressed in a python program after takeoff with the controller. For the one that failed, I pressed the key several times, but it did not move. (The recorded time is midnight, but don’t worry about it because my computer’s clock was messed up. Part of the drone’s individual information and location information is hidden.)

Thanks in advance to all who respond.

This topic was automatically closed after 30 days. New replies are no longer allowed.