No fstcam_stereo_depth_filtered with simulated drone


I’ve followed the Hello World tutorial and I’m trying to understand the cv-service.

I’ve tried it with Sphinx and I succeed to make the drone will “say” Hello moving its head.
Unfortunately, the cv-service seems to doesn’t receive frame from fstcam_stereo_depth_filtered. If I change #define VIPC_DEPTH_MAP_STREAM "fstcam_stereo_depth_filtered" to #define VIPC_DEPTH_MAP_STREAM "fcam_streaming", the service start and I can do some stuff in do_step of processing.cpp.
When VIPC_DEPTH_MAP_STREAM is set to fstcam_stereo_depth_filtered, the frame_cb is never called and processing thread_entry is waiting for it (pthread_cond_wait).

I’m trying to figure out why fstcam_stereo_depth_filtered doesn’t send any frame to frame_cb.
I launched Sphinx with_depth_hil = 1 using real anafi_ai hil_ip.

Any idea ? Anything I can check to make sure simulated drone feed fstcam_stereo_depth_filtered ?



with_tracking_hil and with_depth_hil options require a firmware version that is not available for download. You can’t activate these features with a regular firmware.

With default with_depth_hil=false, the depth in fstcam_stereo_depth_filtered is generated by Unreal.

Hi @ocrave,

If I set with_depth_hil=0, I have the same problem, frame_cb that subscribe to fstcam_stereo_depth_filtered is never called …

This topic was automatically closed after 30 days. New replies are no longer allowed.