No video feedback on Sphinx


#1

Hi !
I run Sphinx on ElementaryOS Loki version (which is based on Ubuntu 16.04) and so far I’ve been able to run the simulator, to fly a simulated Bebop and a simulated Disco with my SkyController2 and OnePlus2, but with either one of them I haven’t succeed so far to get a video stream feedback :confused: The phone keeps displaying “not recording” :confused:

Had anyone already have this issue ?

Thanks !


#2

Hi !

I know this might not seem obvious unless you’ve read the documentation carefully but have you enabled the video option (sphinx --enable-video) ?
On Bebop and Disco, the front camera rendering is deactivated by default to save some precious FPS :wink:

If that does not solve your problem could you please give us some details on your configuration (gpu reference, gpu driver version, …).

Please have a look at the system requirements page :

Matching the minimal system requirements is not sufficient to enjoy every simulator features. This is particularly true if you want to activate the drone cameras **(--enable-video option)** or access the simulated drone WiFi from a FreeFlight application on your smartphone. See the recommended system requirements below for more information.

[....]
Graphics card

An NVIDIA graphics card using the latest proprietary drivers is strongly recommended. Besides, when activating cameras, especially fisheye cameras, a high-end GPU (e.g. GTX 980 Ti) becomes necessary.

For your information it is probable that in a future release of sphinx we may remove the enable-video option in favor of a more consistent solution.

Regards
Nicolas


#3

Hi,
Indeed I misread the documentation, I read that the --enable-video is only required for the minidrones and I interpreted that as “the other don’t need the option, it is activated by default” :confused: http://developer.parrot.com/docs/sphinx/drone-requirements.html

In the drone file for each of my drones, the sdf params contains :
Bebop :
> <sdf_params

    low_gpu="false"
    with_bumpers="false"
    with_front_cam="true"/>

Disco :

sdf_params low_gpu=“true” with_front_cam=“true”/>

(I tried with low-gpu true and false :confused: )

When I add the --enable-video option, the freeflight pro is not able to connect anymore to those drones, the console keeps spamming :

[Err] [Socket.cc:171] Socket 76 hung up
[Err] [Socket.cc:171] Socket 76 hung up
[Err] [Socket.cc:171] Socket 76 hung up
[Err] [Socket.cc:161] Error on socket 76, closing it

But yeah, just as you, I suspected my GPU :confused: I didn’t expect a 10fps, but at least 1 image, even when not flying, for tests purpose :confused:

Here is the result of :

sudo lshw -C video

->

*-display
description: VGA compatible controller
produit: Intel Corporation
fabriquant: Intel Corporation
identifiant matériel: 2
information bus: pci@0000:00:02.0
version: 02
bits: 64 bits
horloge: 33MHz
fonctionnalités: pciexpress msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
ressources: irq:129 mémoire:eb000000-ebffffff mémoire:a0000000-afffffff portE/S:f000(taille=64) mémoire:c0000-dffff

Thanks for your time ! :smile:


#4

I would expect you to experience a ~0.10 real time factor with low_gpu=true (also I don’t want to give you some false hope…)

Anyway, the socket hung up error might be a symptom of a simulated firmware crash. This should not happen even with an Intel GPU with the low_gpu option enabled. That would explain why FreeFlight is no longer able to connect to the drone… :wink:

I will try to reproduce and investigate this issue. Let me get back to you when I’ll have more information.


#5

Hi guys,

I am having similar problem.With active front camera settings on Disco model with_front_cam=“true”
Simulator is crashing constantly with similar messages in the logs:
[Err] [Socket.cc:174] Socket 82 hung up
E pomp: recvmsg(fd=84) err=104(Connection reset by peer)
[Err] [Socket.cc:164] Error on socket 82, closing it
E pomp: recvmsg(fd=81) err=104(Connection reset by peer)
[Err] [Socket.cc:174] Socket 82 hung up
[Wrn] [Publisher.cc:141] Queue limit reached for topic /gazebo/default/user_camera/pose, deleting message. This warning is printed only once.

The strange thing is that I am getting nearly constant FPS around 60, but the Real Time Factor is dropping bellow 0.05 (it stays in range of 0.95+ without front camera) and I don’t see any video stream on my phone at all.
I tried to create complex world without front camera and I don’t get any problems rendering it.

OS: Ubuntu 16.04
Wifi: EP-N8531
Skycontroller2 flashed with latest firmware
HTC One
CPU: AMD FX8150
RAM: 12GB @ 1333MHZ
VIDEO: Saphire Nitro+ RX480 8GB DDR5 + amdgpu-pro 16.30-3 + vulkan SDK 1.0.37

I am really out of ideas what could be the problem. Any help will be greatly appreciated.


#6

Hello,

Gazebo is known to run better with Nvidia cards. You could try running sphinx with the option low_gpu=“true” to ease off graphics demand. You could also install the “radeon” driver and see if that works better but I doubt it.