Noob post: installing sphinx

I am trying to install Sphinx from Installation procedure — Parrot-Sphinx 1.2.1 documentation
but when I tried install the packages, received the error message.

anyone can help out here?

Sphinx 1.9 is not available on ubuntu focal: System requirements — Parrot-Sphinx 1.2.1 documentation
You should use bionic instead.