Olympe Commands - Delay

Hi there,

There seems to be a noticeable delay, up to 10 seconds, after each command I invoke.
So, by the time I send the command till the execution begins I have this delay.

I have tested this in various configurations and various systems and VMs also.

Is this normal? Can I boost somehow the Olympe library and get my commands executed more quickly?

Best,
George.

Hi g0d,

I think this could theoretically be possible if you were sending/receiving a lot of message to/from the drone (something like >~1000 messages/seconds).

Anyway, this issue is completely new to me, could you please provide more context on your application?

  • Are you sending a lot of commands?
  • Do you have the video streaming enabled?
  • Would it be possible to share some logs where you’re able to reproduce this issue?
  • Are you using a simulated or a physical drone?
  • What is the wifi link quality?
  • Are you using a SkyCtrl3?

Thanks

Nicolas

1 Like

Hi,
No I am sending just one command every 5 or more seconds. Otherwise if I send more commands, they end up crashing each other. I guess ANAFI does not have a queuing mechanism to handle more than one actions at a time…?

  • Are you using a simulated or a physical drone? Real drone
  • What is the wifi link quality? 95%
  • Are you using a SkyCtrl3? Nope. Linux computer

I also have the streaming enabled. Why does this make a difference?

Best,
George

ANAFI should not have any issue handling multiple requests in parallel. We’re doing it all the time…

Well clearly it does with Sky Controller but certainly not with Olympe…

Best,
George.

If every user of Olympe were to hit this issue, trust me we would know! The problem must be triggered by your particular setup… Just to be clear, I am not saying you’re not having any issue. I just need more information if I want to reproduce it.

What are the commands you’re sending?
Do you send piloting commands in parallel? (piloting_pcmd?, PCMD command ?)

I don’t understand, can you clarify your last sentence? Do you mean that you’re encountering this issue only when Olympe is connected directly to the drone and not when it’s connected through the SkyCtrl3?

The video streaming wifi congestion control software is only fully operational if the SkyCtrl3 is connected to the drone (with or wihout Olympe on top of it) and with the video streaming enabled. That’s why I asked about the wifi link quality, the usage a SkyCtrl3 and the video streaming.

Hi Nicolas,

Please see my answers below:

  1. No, I am sending simple serial commands like TakeOff, Land, etc. (and waiting for them to finish)
  2. I don’t connect the Sky Controller 3 anywhere. I use Olympe and talk to ANAFI via WiFi.

So, If I understood correctly when the Sky Controller is connected there’s some sort of QoS applied. Otherwise all packets are First-Come-First-Serve. So, what you are telling me is that my command’s being flooded over the 4K streaming packets?

Is this maybe the reason why sometimes it takes ages for me to open the live stream on 192.168.42.1 or have disconnections all the time? Can I compensate somehow for that?

Best,
G.

Any comments on the above Nicolas?

There is nothing wrong with that it would possibly be problematic if you were spamming the drone with those messages.

It would be interesting to connect Olympe with your ANAFI through a SkyCtrl3 to compare the results.

Yes, some sort of QoS is applied with the SkyCtrl3 but that’s NOT all. There is a lot of things we do between the SkyCtrl3 and the Anafi to make the WiFi link more robust. It’s kind of a complex subject but the least I can say is that we just can’t achieve the same performance with some random consumer wifi dongle.

Hoo, thanks no! We don’t stream the video in 4K (only the recorded video on the drone is in 4K) that would definitely flood your wifi link :wink:

Without a SkyController3 between your linux box and the drone, you should try disabling the video streaming to see if it improves the situation. If that’s the case, it means that your WiFi link is not as good as you might think (the RSSI may be strong but you may have a noisy neighbor). You should probably try to change to another wifi channel (the SkyController would do it automatically though).

Unfortunately, I don’t have time to reproduce this issue for now. Anyway the next release of the SDK is on its way. So even if we identify a bug at this point it’s probably already too late for this release. I’d really appreciate if you could quickly confirm my suspicions above though. Once we have a good understanding of what’s happening we will update the documentation to recommend the usage of a SkyController3 with Olympe and ship a bugfix if necessary.

Thanks