Olympe installation success- V1.8.0 with Linux Ubuntu V20.04

Hi,
I have the following error on my new Ubuntu 18.0.x Linux version when I run the command line " repo init -u https://github.com/Parrot-Developers/groundsdk-manifest.git"

File “/home/sibu/code/parrot-groundsdk/.repo/repo/main.py”, line 79
** file=sys.stderr)**
** ^**
SyntaxError: invalid syntax

It’s a python version error with repo

You can install the last version of repo using the following commands:

  1. Make sure that you have a bin/ directory in your home directory and that it’s included in your path:

mkdir ~/bin $ PATH=~/bin:$PATH

  1. Download the Repo Launcher and ensure that it’s executable:

curl https://storage.googleapis.com/git-repo-downloads/repo > ~/bin/repo $ chmod a+x ~/bin/repo

  1. Make it executable by Python 3:

sed -i.bak -e 's;#!/usr/bin/env python$;#!/usr/bin/env python3;' ~/bin/repo

1 Like

Hi,

I had to run the following line of code
" whereis python3"
" sudo ln -s /usr/bin/python3 /usr/bin/python "

AND then I ran the following codes

sudo apt install git
git config --global user.email " your email address"
repo init -u https://github.com/Parrot-Developers/groundsdk-manifest.git

Everything completed until this step…thank you :slight_smile:

mkdir -p ~/.bin
PATH="${HOME}/.bin:${PATH}"
curl https://storage.googleapis.com/git-repo-downloads/repo > ~/.bin/repo
chmod a+rx ~/.bin/repo

THEN FOLLOW THE STEPS

cd $HOME
mkdir -p code/parrot-groundsdk
cd code/parrot-groundsdk
repo init -u https://github.com/Parrot-Developers/groundsdk-manifest.git
repo sync
./products/olympe/linux/env/postinst
./build.sh -p olympe-linux -A all final -j
source ~/code/parrot-groundsdk/./products/olympe/linux/env/shell
python -c 'import olympe; print("Installation OK")'
2 Likes

successfully completed on Ubuntu V20.04

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.