OpenPGP Error with Credentials

I have received the credentials from the team and am trying to install Parrot Sphinx via the Installation procedure provided. However, I run into an “No valid openGPG data found” error, and quick troubleshooting indicates that this may be due to certification issues. Is there anything that I can do? Or is it actually on my end?

OS: Debian 11 bullseye
Kernel: x86_64 Linux 5.10.0-16-amd64
Shell: bash 5.1.4
CPU: 12th Gen Intel Core i7-12700H
GPU: GeForce RTX 3060 Mobile / Max-Q

Regarding the apt error message, try this:

echo 'Dir::Bin::Methods::ftp "ftp";' | sudo tee -a /etc/apt/apt.conf.d/99local-ftp

Also through the crossed-out username and password I noticed it looks like you are including the < > characters in the username and password. Try removing those characters.

I still get the exact same errors.

The FTP server is currently down but you should be able to install sphinx from our new public apt repo :

echo "deb http://debian.parrot.com/ $(lsb_release -cs) main generic" | sudo tee /etc/apt/sources.list.d/debian.parrot.com.list
sudo apt-get update
sudo apt-get install parrot-sphinx

I get the error:

W: GPG error: http://debian.parrot.com bullseye InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 0E7B06B74BAC289C
E: The repository 'http://debian.parrot.com bullseye InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.

What do I do?

I also tried to get the public key using sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 0E7B06B74BAC289C but:

Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
Executing: /tmp/apt-key-gpghome.nvUH40TEez/gpg.1.sh --keyserver keyserver.ubuntu.com --recv-keys 0E7B06B74BAC289C
gpg: keyserver receive failed: No data

Would you happen to know the reason for the error above?

Hello,

I think you didn’t get the gpg key.

Try

curl https://debian.parrot.com/gpg | gpg --dearmor | sudo tee /usr/share/keyring/debian.parrot.com.gpg