Running the demo application on ubuntu

I’m currently using Ubuntu 18.04 and following the tutorial: Install and build GroundSdk - GroundSdk Android 7.0

But I keep getting the same error:
leontjuh@ubuntu:/opt/groundsdk$ ./build.sh -p groundsdk-android -t build -j
[I] Installed NDK version: r17c
/opt/groundsdk/products/groundsdk/android/config/product.mk:43: Missing ANDROID_ABI using armeabi-v7a
[I] Starting task ‘build’
[I] Starting task ‘build-jni’
[I] Starting task ‘build-common’
[I] Starting task ‘build-common-armeabi-v7a’
[I] In ‘/opt/groundsdk’: ALCHEMY_HOST_OUT_BUILD="/opt/groundsdk/out/groundsdk-android/host/build" ALCHEMY_HOST_OUT_STAGING="/opt/groundsdk/out/groundsdk-android/host/staging" ALCHEMY_TARGET_CONFIG_DIR="/opt/groundsdk/products/groundsdk/android/config" ALCHEMY_TARGET_OUT="/opt/groundsdk/out/groundsdk-android/armeabi-v7a" ALCHEMY_TARGET_PRODUCT=“groundsdk” ALCHEMY_TARGET_PRODUCT_VARIANT=“android” ALCHEMY_TARGET_SCAN_ADD_DIRS=" /opt/groundsdk/packages" ALCHEMY_TARGET_SCAN_PRUNE_DIRS=" /opt/groundsdk" ALCHEMY_USE_COLORS=“1” ALCHEMY_WORKSPACE_DIR="/opt/groundsdk" ANDROID_ABI=“armeabi-v7a” PARROT_BUILD_PROP_GROUP=“drones” PARROT_BUILD_PROP_PRODUCT=“groundsdk” PARROT_BUILD_PROP_PROJECT=“groundsdk” PARROT_BUILD_PROP_UID=“groundsdk-android-20211109-0658-0.0.0” PARROT_BUILD_PROP_VARIANT=“android” PARROT_BUILD_PROP_VERSION=“0.0.0” /opt/groundsdk/build/alchemy/scripts/alchemake -j 2 all sdk
Installing Android-24 toolchain from NDK
Traceback (most recent call last):
File “/opt/android-ndk-r17c/build/tools/make_standalone_toolchain.py”, line 666, in
main()
File “/opt/android-ndk-r17c/build/tools/make_standalone_toolchain.py”, line 650, in main
sysroot_path, args.stl, host_tag)
File “/opt/android-ndk-r17c/build/tools/make_standalone_toolchain.py”, line 423, in create_toolchain
copy_directory_contents(gcc_path, install_path)
File “/opt/android-ndk-r17c/build/tools/make_standalone_toolchain.py”, line 147, in copy_directory_contents
os.makedirs(dst_dir)
File “/usr/lib/python2.7/os.py”, line 150, in makedirs
makedirs(head, mode)
File “/usr/lib/python2.7/os.py”, line 150, in makedirs
makedirs(head, mode)
File “/usr/lib/python2.7/os.py”, line 150, in makedirs
makedirs(head, mode)
File “/usr/lib/python2.7/os.py”, line 157, in makedirs
mkdir(name, mode)
OSError: [Errno 13] Permission denied: ‘/opt/groundsdk/out/groundsdk-android’
ls: cannot access ‘/opt/groundsdk/out/groundsdk-android/armeabi-v7a/toolchain/bin/*-objdump’: No such file or directory
/opt/groundsdk/build/alchemy/toolchains/linux/bionic/selection.mk:71: *** Failed to detect android toolchain prefix. Stop.
[E] Command failed (returncode=2)

anyone who knows how to fix this?

Hello, you can’t build the SDK from the source yet.
You need to get the AAR libraries.

Dear Jerome,
I’m further in the process of starting the demo application groundsdkdemo. I’m able to get it on my android device, but the application closes immediately. While closing I get the following error:

java.lang.UnsatisfiedLinkError: dlopen failed: library “libsdkcore.so” not found

Any idea how to solve this error?

Thanks in advance!

Leon

Hi,

SDK 7.0.0 source have not been deployed on github yet, so you won’t be able to build groundsdkdemo.
Using the latest groundsdk 7.0.0 aars available on mavencentral won’t help you either, since groundsdkdemo source code on github matches 1.8.1 version of the SDK and not 7.0.0 yet.

The error you get at runtime tells that groundsdk native library has not been embedded in groundsdkdemo, hence the application cannot run.
Which is expected, since the native build failed as you mentioned in your first post.

Regards,

Mathieu

Hi Mathieu,
So there are’nt any examples I can use for reference? Is there any other way to get started with Parrot-programming? Are there any other working Parrot-platforms to get started? Or do I need to wait for the 7.0.0 release?
Thank you for the quick reply and thanks in advance for answering my questions!

Regards,

Leon

For SDK 7.0.0, no there is no source reference yet. Only the installation/build docs have been updated to mention 7.0.0.

The actual sources available on github, for now, correspond to version 1.8.1 of the SDK. You may want to look at them for reference until we properly publish version 7.0.0.

That said, your build should work and build a 1.8.1 version. The instructions listed in the tutorial have not changed much. Have you tried to clear your workspace completely (rm) and follow the instructions once again ?
Could you do it once again and provide the complete log of all your input command and all output messages so that I can look deeper at your issue ?

Regards.

The issue got resolved when i intalled ubuntu 20.04 instead of 18.04

1 Like