Sphinx firmwared

I am working on using the Sphinx software to simulate a Parrot Anafi Drone.
At the moment, I am experiencing problems with the quickstart example related to the firmwared daemon.

For example, when I run
phinx “/opt/parrot-sphinx/usr/share/sphinx/drones/anafi_ai.drone”::firmware=“https://firmware.parrot.com/Versions/anafi2/pc/%23latest/images/anafi2-pc.ext2.zip

the system returns
Parrot-Sphinx simulator version 2.9.1
The connection to the firmwared has timed out.

I have searched for a solution on the web but there is not enough information about this problem.

Is it possible to have some support from you about the correct installation and use of these software tools.

Hello,

At the end of the installation, you need to log out from your session, then relog to complete the installation.

Then you must start firmwared before Sphinx with:

sudo systemctl start firmwared.service

To make sure that firmwared is running you can try:

fdc ping

Hello, After using the commands you mentioned it still doesn't fix the problem, I have started the firmwared before and checked with the fdc ping command but it still fails. The Unreal4 part is still running ("parrot-ue4-empty").

What error message do you have?

When running the command sudo systemctl start firmwared.service and the command sphinx “/opt/parrot-sphinx/usr/share/sphinx/drones/anafi_ai.drone”::firmware=“https://firmware.parrot.com/Versions/anafi2/pc/%23latest/images/anafi2-pc.ext2.zip
command displays this error:
[Msg] Waiting for a UE4 application to start…
[Msg] World params for ‘default’:
[Msg] spawn_points:
[Msg] - name: default
[Msg] pose: -3.3 0 0.4 0 -0 0
[Msg] connected to firmwared
[Msg] Preparation of firmware https://firmware.parrot.com/Versions/anafi2/pc/%23latest/images/anafi2-pc.ext2.zip
[Err] [PompPool.hh:143] Received an error from firmwared: curl.hook/probe failed. See ulog for details.
[Err] [AutomatonPrepFw.cc:83] Preparation of firmware for machine anafi_ai failed. Check your path or URL to the firmware.
[Msg] All drones dropped. Let’s shut down.

Can you start ulogcat to see logs produced by firmwared? The procedure is explained here: Troubleshooting - 2.9.1